Running XP via Fusion

garigoun

Registered
Hi I'm a new poster, hope you can help. I've been running Fusion 3 for about a year now on Snowleopard with no problems right from the installation. Today I got a window informing me that 'Fusion 4 is available. Tried to find if I could upgrade without success. I then downloaded the trial version of Fusion 4. Would not work because the earlier version was running. Tried to shut down the earlier version and now I cant run either of them. I just get a window telling me that the virtual achine is out of date and to change my settings. But all the options in 'Settings' are greyed out. So I now have no access to all the stuff on my Windows XP virtual machine. Any ideas please
Gari
 

Giaguara

Chmod 760
Staff member
Mod
Fusion (and Parallels and a few other programs) need some additional help files to function in the system. Such as kext, kernel extensions. After it has installed them, the system will have to be rebooted for the change to take effect, otherwise your virtual machines (or the whole virtualization layers) will not work.

So if there is a problem updating still Fusion (or if it's solved now, then for whoever else might run to this issue later), shut down (not suspend but shut down) all the virtual machines, and quit Fusion. Uninstall Fusion. Reboot the system. Now install Fusion 4, and after it has installed, reboot the system again.

Now launch the virtual machines. It should complain about the VMware Tools being out of date, so first uninstall the VMware Tools inside the virtual machine (control panel>Applications or other appropriate method depending on systems), reboot the virtual machine, and now select to install the VMware Tools, and after successful install, reboot the virtual machine once more. Again, you could do the "upgrade the VMware Tools", but it's better to first uninstall them correctly to make sure all components are new and faultless.
VMware Tools inside the virtual machine also need the virtual machine rebooted, since also they have components that work deep in the system.

If the VMs options are still grayed out, try to shut down the virtual machine manually or by force. Then when it's booted, you should have a better chance of removing the out of date Tools.
 
Top