Samba server (smbd/nmbd) problems

skinlayers

Registered
ARG!
I got a 10.1 (5G64) update CD, co I wiped my OS X partion, reinstalled 10.0 and immediantly updated it to 10.1. To get my smb/cifs shares back up, I reinstalled samba 2.2.1a from http://xamba.sourceforge.net. It installed find, but I am unable to connect. When running "top" from a terminal windows, i see that smbd is running, but nmbd is not. Even if I execute nmbd from the command line, it do not show in "top". Could this have to do with 10.1's build in smb client?

Thanks,
Skinlayers
 

Tom C

Registered
I've had a similar problem. When I first set up Samba X 2.2.1a, I couldn't get it to work: the share wouldn't appear in the Network Neighborhood on the Windows machine. I didn't have time to troubleshoot.

When I upgraded to 2.2.2 about a week later, everything suddenly worked, so I figured that there was a bug in 2.2.1a. However, after a restart on my Windows client and after changing the Samba X configuration with SSCT, the problem has reappeared. No share in the Network Neighborhood.,

I went to the CLI and discovered the same thing: nmbd is NOT running. I tried starting it from the CLI (I have a decent book on Samba with full instructions) to no avail. (Yes, I tried starting it with sudo - sudo nmbd -D.) The process gets assigned a process number, but apparently quits immediately.

If you look for the share from the OS X box at the CLI using the Samba client (smbclient -L sharename), you won't find it, so the problem is clearly on the OS X end.

I don't think that the problem is related to Apple's SMB client, because during the short period that I was successful in seeing my OS X share from Windows, I had both Samba and the Apple SMB client running simultaneously...my OS X machine could see my Windows machine, and vice versa. I suppose that it's possible that Apple's SMB client interferes with nmbd's startup, but won't interfere with its operation once you get it going. Still, I've tried starting up nmbd from the command line with Apple's SMB client both on and off, to no avail.

Any ideas, anyone?
 

rharder

Do not read this sign.
I had a problem with nmbd not wanting to run, but after I installed the samba for X package (I think from the pages you mentioned earlier - I don't remember) then everything was fine.

-Rob
 

~vert

It's short for vertigo...
I had the same problem after upgrading to 2.2.2, which instantly made my access to SMB unavailable from my Win box. The SWAT tool showed that smbd was running and nmbd wasn't. So I used the directions to delete Samba X (sudo /usr/local/samba/removesamba) and reinstalled 2.2.1. No luck. So I deleted it again and then used Sherlock to search for any files/folders named Samba or smb and moved them to the trash, logged out, and then reinstalled 2.2.1. I noticed that I also had to clear the cache on my browser so that the SWAT tool showed the buttons to start/stop smbd and nmbd (these were mysteriously missing after the upgrade to 2.2.2). Once I had a clean browser cache I could reset both processes and it has worked fine ever since. I have no plans on moving up to 2.2.2 until I am sure that it doesn't introduce a bug - and 2.2.1 is filling the bill anyway.

I also found that using the SSCT (Samba Server Config Tool) that you can download from here helped tweak the settings easier than using the HTML tool SWAT. One thing I noticed is that after I had the upgrade fiasco, SSCT tend to quit unexpectedly. It's a know bug, but is thought to be related to DAVE - however I have never installed DAVE, so there you go...
 
Top