Screen Loops Back to Login Screen

mimonaco

Registered
Whenever I try to login, the computer accepts my name and password and brings up the desktop for just a few seconds. After just a few seconds it loops back to the login screen.

I was just curious how that could be corrected or if there was a way that I could get around the login screen and just go straight to the desktop. I know that I can make the computer automatically sign me in but I have to be able to get the desktop to stay open to do that.

I would appreciate any help that someone could give me about this problem and how it can be corrected. I have an iMac (a flat screen with a bubble base) and it is running Mac OS X (not sure which version).

 

cheetybum

Registered
I have exactly the same problem on my 17" powerbook G4.

I've tried zapping the PRAM, safe mode, first aid via
target mode and everything else I can think of. But no good.

Did you fix yours yet?
 

Giaguara

Chmod 760
Staff member
Mod
Hold down shift after the login screen.
Does that give a better login result?
 

cheetybum

Registered
Holding shift down does no good either. Even if I hold shift down from a full shutdown I'm still immediately returned to the lopgin page after the briefest of glancesat my desktop.
 

Giaguara

Chmod 760
Staff member
Mod
Do you have any other users in the system to log in as?

If not, try this.

Start up in single user mode (command-s at startup)
at prompt type the following -- after each line hit enter, and wait for prompt to enter next line

Code:
/sbin/fsck -yf 
mount -uw / 
rm /private/var/db/.AppleSetupDone 
shutdown -r now
Then start up normally. You'll see the setup assistant, so create a new user. Your old user is still there so nothing to worry. When the new user is in, you can try e.g. to change in the system preferences the old account to automatically log in. Also see if there is anything in the startup items for your old user - disable all before you start up again to log in as old user.

If even that fails let me know ..
 

cheetybum

Registered
I have a troubleshhoter user with admin access but the same happens when I log on using that one.

I've tested the disc with disc warrior which says it is physically okay. Any idea what I can try next?
 

Giaguara

Chmod 760
Staff member
Mod
So it's not something that affects only that user ...
Did you change anything or install new updates or software just before this happened? Or any new fonts etc? Any accidental shutdowns or anything that you could think that could have affected this?
Have you tried to repair the permissions from Disk Utility (of Mac OS X install disc 1)?
If you try to log in verbose mode (command-v) you can see what happens in the login process.. any clues in verbose of why this is happening?
How much empty space do you have? I might consider even archive and install soon..
 

cheetybum

Registered
Tried to repair permissions via system disc and it was unable to repair. So I'v ejust reinstalled system 10.4. First time around I just got the console on start up. So installed it all over again.
It is now up and running, apparently without too much of a problem - I'm just updating to 10.4.10 via apple. Hopefully normal service will then be resumed.
 

Giaguara

Chmod 760
Staff member
Mod
Would be still interesting to find out which program or thing caused that to occur. :-/
 
Top