Script Editor 2.0 Hangs When I Try to Open Any Script

zeke_mn

Registered
System: iBook G4 933 256MB 10.3.9

I used script editor for the first time about 2 weeks ago. I wrote my first short scripts and used "save as" to save them as an application so my son could use it while I continued to edit and improve the script. I am not sure, but I think I was able to go back and edit the scripts at first, but perhaps I just ran them until I got a decent result, and then saved it as an application.

Anyhow, I cannot open any script at all, even the simplest examples that came with the system. When I try to open any script or edit the application I wrote, Script Editor 2.0 hangs (spinning beach ball) and I have to do a "force quit." If I run Activity Monitor while I try this I see the CPU use go to the max, and it shows Script Editor hanging. Even if I just open Script Editor and go to "Open Recent" on the file menu, I get the spinning beach ball, and I have to do a force quit.

What I've tried so far:
1. repaired disk permissions (twice) using Disk Utility.
2. Cleared system cache using Cache Out X (at least twice.)
3. Checked plists using Preferential Treatment utility.

I am thinking of upgrading to Tiger anyway. Maybe that would fix this. But I sure would like another solution for right now.

Thanks
Steve
 

bobw

The Late: SuperMacMod
Try trashing the preference file;

com.apple.ScriptEditor2.plist

located here;

user>library>preferences
 

zeke_mn

Registered
Thanks Bob. While I was waiting to hear a response, I got Tiger and did an archive and install. That fixed the problem.
 
Top