sendmail problems (domain of sender does not resolve)


hello all!

i have configured sendmail, and all appears to be well. i can telnet to port 25. when i try to send mail from, i get the following error in my mail.log file:

reject =451 4.1.8 Domain of sender address xxx@xxxx does not resolve

xxx@xxxx is a valid email address... any ideas?

Hi Level42,

I get the exact same error... allthough, I think it worked correctly the first time I got it running... (I can't recall making any changes)

I guess it has something to do with what you set the host parameter to in the files you edit.

Everything works fine if I tell to use my account, but not when I want it to use my "normal" account.

Please let me know if you have solved this.


i ended up going with qmail, and it has always worked wonderfully.. i would recommend switching to that if you can...

OK, downloaded qmail 1.03, but I don't think it's compiled... If you have the time, would you please go through the steps you had to do to remove sendmail and compile and install qmail?

Have a nice evening!