Serious PPPoe Problems. Need Help! Who's smart enough?


I'm having problems connecting to the internet via OSX's "Built in" PPPoe.

I configure my OSX "Network" settings in the "System Preferences" per Earthlink's DNS numbers etc. (I have Earthlink DSL). Everything is put in correctly, however when I try to connect nothing happens.


I can successfully connect ONLY.....AGAIN ONLY, if I first switch my network connection from "Built In Ethernet" to "Internal Modem" hit the "connect" button and then quickly switch back to "Built In Ethernet" and then quickly hit the "connect" button.

I don't want to have to connect this way. I want only to have to hit the "Connect" button while using "Built In Ethernet".

Why does this do this? How do I fix this? Does anyone really know enough about OSX to know what the heck is causing this and how to fix it?

My patience is running are my pills.


Configure Advanced under network and either disable the internal modem or move it below the built in ethernet. I have Earthlink as well and had the same problem.


I already tried what you suggested and even tried once more. Still doesn't work! Who really knows the answer here?

G4 400 Tower (Sawtooth) 576 MB RAM
10 GB OS 9.1
10 GB OS X w/ clean 9.1 for classic
Apple 17" ADC Studio Display
Currently running Build 4P13/10.0.3

Earthlink/Mindspring/Covad DSL 1.5mbs




Why don't you try the modifiying the packet size as described in the discussion started by Bebox in the thread "10.1 upgrade and PPPoe".

Hope it helps ;)