Services???

blo

Registered
I've formatted my x partition, installed 9.2.1 and then 10.1;

everything is fine (well, really cool...) but all my services are greyed out;

I'm not the only one having this problem, and couldn't find any suggestion around (forums.macnn is online now, but didn't helped)

cmon, help a 10.1 happy user!

(btw, I wuold really love to try the terminal services...)
 

Red Phoenix

Registered
This may seem stupid, but you are selecting something when you go to the services menu, right? Just trying to narrow things down...

Also, some Carbon applications have the services menu, but it's not usable, yet. I'm using Mozilla, which has it and it is completely and utterly useless. As far as I can tell, it's the same with the Finder. Try selecting something in TextEdit and going to the services menu. This should work.
 

blo

Registered
I've tried to use the services "in the right way";

e.g. selecting a .dmg file and tried "Disk Copy" from the services menu; selecting some text and then Services:Mail...
they just don't work;

tried TextEdit, and... the services DO WORK!
wtf????

so what's the use of all the services 10.1 has if they are all grayed out *except in some rare apps* ?

for example, how can I use the services provided by disk copy? maybe using finder alternatives like snax?

and what about "grab"? I thought that should always work ...

tnxs for the reply, I'm starting to understand (that something is broke in 10.1, right?)
 

Javintosh

Meember
Based on this, services are pretty useless at the moment. What determines whether services are available to an app or not?

Javintosh
 

Red Phoenix

Registered
A Cocoa application that has text that is selectible almost always uses services. The carbon ones don't really seem to be able to use them without being modified.

Personally, I use services a lot, because OmniDictionary adds a service to look up a word.
 
Top