Setup Assistant Stops Partway Through Conclusion


I have a beige G3 Minitower, 233 mhz, 96 MB RAM (to be upgraded to 320 MB tonight! but I don't think that's the issue here), 30 gig ATA hard drive. After a couple of scares (Apple isn't kidding when they say the partition OS X get installed on must be in the first 8 gigs), I got OS X installed and it boots up to the Setup Assistant. I can fill all the information out, no problem, but when it gets to the final step (conclusion) it stops maybe 1/6 or so of the way through applying the settings. I can quit the Assistant if I want, but then it just starts up all over again. Same thing if I force quit it with command-option-escape. I have a cable modem; I tried configuring it to just use DHCP all the way, I tried manually entering all my TCP/IP information, and I tried telling it that I had no network connection at all. It always hangs at pretty much the same spot (The status bar got a few pixels further when I set it up with no network connection).
Has anyone seen this? Is there anyway I can avoid using the setup assistant and manually configure some files or something? I have OS 9 installed on the OS X partition, but I use 8.6 on a separate partition for everyday use. I could easily modify the files OS X uses since the partition is HFS+.
Any ideas?
Thanks in advance.