Single User Mode



We recieved a MacOSX machine in at work today. I do not know the root password and wish to change it. When I boot the machine into Single User Mode and attempt to passwd I get a message saying something like "User root not found in NetInfo." I have also tried the Administrator and administrator,it gives me the same result. I was wondering if anyone could help me out.


Apple states that it is very important to know the Administrator password when you setup a computer. Without this password, you cannot change settings on the computer.

One workaround is to boot from a Mac OS 9 CD, backup your important files (which you've done already - right?) and reinstall Mac OS X. Sorry, but single user mode opens the file system as read-only. Only an Administrator has privileges to change its contents below /Users.
Actually single user mode bypasses the startup items including NetInfo thus using the traditional /etc/passwd which has NO PASSWORD SET. Just login as root with no password, fix your computer, then stop using single user mode. It's not to be used unless your computer is screwed up