slow upload

Racer D

what?
I have a linux machine 2mbit/384kbit adsl connection and 2 machines connected to it. on linux machine itself and a windows machine internet works fine, I get upload speeds of around 30-40kb/s

but on my g5 imac & OS X.4.2 my upload seems to have some strange problems. It varies from 0-16kb/s. I've tried this with a few ftp proggys (including the shell ftp command) and with scp. all the same. upload inside the network is ok though. and so is download from the internet.

I'm monitoring the connection using iptraf on linux and when uploading with imac I get speeds of around 160kbits/s, using windows or linux I get 300+

os x firewall is disabled.

What could be the problem?
 

Racer D

what?
I tried running this test.
on my mac I get:
Max packet size you sent (MTU): 1480
Max packet size you received (MTU): 1480

on the windows machine I get:
Max packet size you sent (MTU): 1492
Max packet size you received (MTU): 1492

--

my ifconfig on the mac:

en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1492
inet 192.168.1.3 netmask 0xffffff00 broadcast 192.168.1.255
ether 00:0d:93:b6:e9:62
media: 100baseTX <full-duplex> status: active
supported media: none autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback>

(same when I set mtu to 1500)

-

could anyone else try running the test, see what mtu you get? thanks
 

Racer D

what?
it's the same if I connect the mac directly to the internet
 
Top