Software update cannot connect to the internet...

Pascal

Official visitor
I know this has been talked over and over, only I have not found a solution to this problem... Has any one succeeded in getting the "software update" of feature Mac OS X to work with a PPPoE connection ?

Here's what happens : after I click on the "update now" button, the "Internet connect" application bounces up while a sheet slides down from the "System preference" window, informing me that "Software update could not connect to the internet".

I have tried :
  • deleting Software update's preferences
  • Changing the DNS in my Network CP
  • Removing all DNS altogether
  • pinging first to apple.com using the terminal
all without any success. Has any one succeeded ?
 

gumse

Member
I have a Static IP, but the same problem (most of the time). The solution for me is to open up www.apple.com in Explorer , then Software Update suddenly works.
 

Pascal

Official visitor
Of course, I updated yesterday thanks to the full update availability in the Apple TILs, but I still find it supremely annoying that certain part of the OS cannot connect to the internet...

I wonder if it has anything to do with the Setup Assistant that did not correctly configure my system initially (the PPPoE option not being accessible at that moment...), although I doubt it.
 

gumse

Member
I have the same problem on another Mac on my internal network (only when running X). My guess is that is has something to do with the fact that I use a Linux Box as a gateway. All other machines and OS'es works ok though.
 

Pascal

Official visitor
I've got the feeling we have the same symptom, but a different disease ! My computer is not connected on a network : my Mac is an island with a link to the world via Internet/PPPoE.
 

gumse

Member
I don't want to rush into any conclusions, but since updating to 10.0.2 i have not encountered any trouble with Software Update, Sherlock or LateBreakingNews. I have tried over 20 times during the day without problems. No "cannot connect.."
Earlier i had problems with this 90% of the time.

Could be luck though, i'll keep testing.
 

Pascal

Official visitor
This would concur with my "same symptom, different disease" theory, since nothing changed here, even though I upgraded to 10.0.2...

Maybe Apple solved your problem, and mine will be solved in 10.0.3. I guess I cannot help being an optimist. ;)
 

VGZ

Registered
To answer your question about getting a connection with PPPoE, yes it works on my computer connected through PPPoE. Have you disabled the dial-up under advanced in Network? I had application say that they could connect before I disabled that in Network.

Good luck and I hope this is somewhat helpful to you,
 

Pascal

Official visitor
Originally posted by VGZ
Have you disabled the dial-up under advanced in Network? I had application say that they could connect before I disabled that in Network.
Yes ! Yes ! Yes ! Yes !
Hip, hip, hip hooray !

Thanks VGZ, you solved my problem ! :D

I had configured the dial-up (modem) tab as a preventative measure, just in case I would need it. I had not realized that doing so would prevent some apps from using the ethernet connection... (even though it was the first in the list) :eek:

As you suggested, I disabled the modem ports and ta-dam ! Software update worked !!! :D

:D Me happy ! :D
 

onan

Prescriptivist

Sorry, I guess I should've also posted this here a few weeks ago:


The "Cannot connect to the Internet" error one sometimes gets from Software Update is due to a small bug in it, and has an easy workaround.

The workaround: visit www.apple.com in a browser, and Software Update will immediately work.

The explanation: there are several different types of DNS records, most notably NS (information about nameservers); MX (information about mail servers); and A ("normal" name/ip mappings). When you interact with www.apple.com your computer gets all of these types, and caches them for an amount of time suggested by the Apple's server.

Apple's server is currently suggesting that you cache A records for one hour, and all others for one day, which is quite reasonable.

When Software Update requests that your computer fetch the address for www.apple.com, it incorrectly asks for "ANY" record, when what it really wants is the A record. If you've looked up www.apple.com in the last day (but _not_ in the last hour), your computer returns what it already has cached (the NS and MX records). Software Update sees that it didn't get back an A record, assumes that you can't talk to Apple's nameserver, and gives up.

Thus, if you just connect to www.apple.com with something that explicitly requests the A record (as Software Update should), you have it cached for another hour, and SU works.

With luck, we'll see a fixed version of this soon; it should be a trivial thing for Apple to correct.


 

Pascal

Official visitor
Thank you Onan... but that solution did not work for me. I had read this tip somewhere else and it did not work in my case (see my very first post).

I guess we can consider my problem (Software update trying to use a dial-up connection despite an ethernet connection being available) and yours (bad usage of a DNS table) as two different bugs that Apple should correct ASAP...
 

VGZ

Registered
Guess its time for a feedback bug report. Maybe it will be fixed in 2 or 3 weeks with the 10.0.3 update (based on the current rate of updates).
 

gumse

Member
Just a follow-up.
Software Update works 100% of the time for me after updating to 10.0.2 , tried 30-40 times for two days now. So i guess that problem was solved in the update.
I hope that you guys get some releif in 10.0.3
 

rharder

Do not read this sign.
Gumse, if you're at 10.0.2, what exactly are you doing with software update to make sure it works?

Anyway, I finally had to download the 10.0.2 update manually, but my PPP connection kept dying with IE 5.1. When I switched to wget, it worked fine. That's a handy little program, that wget. I wonder if I could make internet explorer use wget as its download manager.

-Rob
 

gumse

Member
rharder, I just press "Update Now" and the search for new software begins (even if it finds nothing new right now).
Earlier a dialog came up with "Cannot connect..." at once when i tried this, at least 90% of the time.

I also had problems with Sherlock and the linked pages in Mac Help, all this now works fine. Sherlock just didn't search for anything and Mac Help said: "Cannot connect..."

 
Top