Speech Preference Pane



Earlier this week I tried to set up voice recognition in OS X 10.3.9 which, despite years of using Macs, I've never actually done before.

At first, nothing very much happened. I couldn't get the preference pane to indicate that it was receiving a signal, never mind successfully recognise my voice when I read the test phrases. (I later worked out that the microphone, previously still sealed in its Apple packaging, is probably faulty.)

After a while spent getting nowhere slowly, the situation deteriorated. The Speech preference pane started to crash whenever I tried to open it.

Either it refuses to load (the title bar says "Speech Loading…" but nothing actually happens) or else loads and then crashes within a few seconds, offering me the opportunity to send Apple a bug report.

As I'm fairly new to Mac OS X I'm not yet (and may never be) up to interpreting crash reports, so I've spent hours searching for an article or forum describing the same problem on the Internet. To my surprise, I've found nothing at all. (This despite the fact that I know someone else with exactly the same problem on her Mac.)

I've also spent a good deal of time testing my own theories, but haven't made any progress there either.

Here's my thinking. Since the software appeared to be working at first (with my initial problem apparently being down to a faulty microphone) and then went bad, some sort of corruption is more likely than a conflict.

Accordingly, I've moved all of the .plist files that start com.apple.speech from my User/Library/Preferences folder and restarted my Mac. I've done the same with the com.apple.systempreferences.plist and I've tried moving the entire User/Library/Preferences folder, as well as the Mac/Library/Preferences folder, to the desktop.

And just in case it was a permissions issue, I ran Disk Utility to sort out any problems there.

No improvement from any of this.

Having eventually worked out that Speech in 10.3.9 is exactly the same as it was in 10.3.2, I've used Pacifist to selectively reinstall the following files and folders:


That was followed by a restart, but made no difference at all.

Other than reinstalling my entire System (which I'm extremely reluctant to do) I'm clean out of ideas, so I'd appreciate any help you can offer.

Incidentally, I've tested all of my other Preference Panes and they all open without any problems.

Thanks in advance.

Problem carried through to Tiger, but eventually resolved.

It arose because I missed some of the sounds that I was used to in OS 9, and copied them to the System/Library/Sounds folder when I upgraded to Panther. Two of the old OS 9 sounds that I copied across (Single Click and Whit) don't otherwise appear in the Sound Preference Pane, but are used elsewhere under OS X.

When the Speech component gets confused about there being two AIFF files with the same name in different places, it crashes. Easily resolved by deleting those two files or renaming them. Just put an asterisk at the end of the name of something like that.