Spinning BeachBall-o-Death on startup ....


System is 10.3.9, 1gb ram G4 quicksilver.

Had been getting slow and slower on startup ( According to the user ) up to 5 mins on a restart till desktop was active.

Installed AutomountMaker ( http://jm.marino.free.fr/SMacAutomountMaker.html) on this and 15 other OSX workstations.

All others work fine.

This one worked fine the first time, then the scripts failed to connect to server. Did manual connection to OSX server. Had to walk user through manual login the next day as well.

Today went to the machine and performed a restart, only to get the beachball-o-death. The machine gets all the way to where the desktop icons are about to show ( IE Menu bar up, time up, dock showing ) and then a network server login window appears. User name is filled out, but never get to enter the password. Ball spins forever ( Machine was left alone for over an hour, and ball still spinning )

Ran repair permissions on the drive by booting from OS X Jaguar CD
Ran Tech Tools 4 maintenance utility on the drive
Ran TT4 memory and cache tests - passed
Zapped pram

Restart machine, still same thing :-( Hangs at a network login screen.

Any suggestions? ( Other than Archive and Install OS X again - which BTW looks like due to time constraints, I am going to have to do ) If the suggestions arrive in time, I will try em. If not I want to know for my own knowledge if anyone else had had the same or similar experience and what they did to fix it.

Thought about DiskFirstAid on the drive, but the drive itself isnt reporting any errors.


Archive and install did not work :-(

Was stuck in some sort of network login ( Was NOT caused by Automount Maker, it was a different dialog box that was popping up. )

Eventually had to do the following.

Booted with Jaguar CD
Changed startup disk to OS 9 partition
Booted into OS 9
Removed the appleshare pref files from the OS X system
Booted to X
Could not connect to any appleshare computers, but system would now at least boot.
Performed archive and install of OS X again.

Then and only then, was I able to get the system to boot properly and connect to the OS X server again.

So thats how I was able to fix the issue. Anyone have any additional things I might have tried?