Spotlight Finds Zilch!


My Spotlight, no matter what I give it finds absolutely nothing. This includes searching from within folders. Have tried to add/remove my HD, in order to re-index, to "Privacy" as suggested elsewhere, but nothing happens or appears on the list, when I do so. Spotlight worked a while back after upgrading to OSX Tiger from Panther, but suspect the problem arose after a security update. Any suggestions appreciated.B.
1) Using the mdutil command-line utility in Terminal, turn off indexing for each of your drives. Example:
• $ sudo mdutil -i off /Volumes/your_hard_drive_name_1
• $ sudo mdutil -i off /Volumes/your_hard_drive_name_2
2) Then use mdutil to remove the indexes from each drive
• $ sudo mdutil -E /Volumes/your_hard_drive_name_1
• $ sudo mdutil -E /Volumes/your_hard_drive_name_2
3) Physically remove the .Spotlight directories from the root of each drive.
• $ cd /
• $ sudo rm -fr .Spotlight-V100
(do the same for your second or third drive)
Make sure to carefully type the "rm" command -- a typo could result in deletion of critical files.
4) Use mdutil again to turn indexing back on for each drive
• $ sudo mdutil -i on /Volumes/your_hard_drive_name_1
• $ sudo mdutil -i on /Volumes/your_hard_drive_name_2
5) Spotlight will now re-index all drives and should behave in a normal fashion. (No longer uses 60%-80% of your CPU)