SSH Problem

jdog

Not a Moderator
Hello,

I am having a problem connecting to the sourceforge shell via ssh. I get a bad packet length message. Any idea what that is from? Here is the output:
Disconnecting: Bad packet length -1921929078.

BTW, I can connect to other servers just fine.

Thanks,
-jdog
 

rharder

Do not read this sign.
Have you connected before to SF from any machine?

I got in okay this morning (5 July).

-Rob
 

howardm4

Registered
something in the 10.0.4 update mangled ssh a bit.

You need to force protocol version 1 'ssh -1 machine_name'
or via the ssh config file.

Or you can install the latest openssh s/w
 

jdog

Not a Moderator
Yeah I was able to ssh off a FreeBSD box yesterday with no problems. I will try to force -1 when I get home. It doesn't sound like apple test these updates very well. :confused:

-jdog
 

jdog

Not a Moderator
Just wanted to let you know that -1 did work! I wonder if I would be better off/more secure if I did my own install of ssh? Any thoughts? It would probably just get fscked when I updated again huh?

-jdog
 

extra88

Registered
I also experienced the problem with OpenSSH in Mac OS X 10.0.4 and forcing SSH1 is a workaround. The only thing I could connect to using SSH2 from osx is a server running SSH Secure Shell 2.1.0 (the "official" ssh). It seems to involve sshd as well. I couldn't connect to my osx box from a RedHat 7.1 running OpenSSh 2.9p1, I got "bad packet length" then too.

I just installed Scott Anguish's OpenSSH-2.9p1 Updater (see above link) and it fixed the problem. It looks like the real problem was Apple updated OpenSSH but not OpenSSL, on which OpenSSH relies.

Mac OS X (included in os update 10.0.4)
OpenSSH_2.9p1, SSH protocols 1.5/2.0, OpenSSL 0x0090581f
OpenSSL 0.9.5a 1 Apr 2000

After Anguish updater
OpenSSH_2.9p1, SSH protocols 1.5/2.0, OpenSSL 0x0090600f
OpenSSL 0.9.6 24 Sep 2000

It also fixed using ssh to connect to the osx box but that required restarting sshd so the new sshd was in use.

sudo kill `cat /var/run/sshd.pid`; /usr/sbin/sshd
 

Digimatt

Registered
Hey extra88, your post is very useful, but I don't see the link that you refer to for Scott Anguish's OpenSSH-2.9p1 Updater. I would love to update my SSH, but I can't find the package you wrote about.

Thanks

:confused:
 

raxa

Registered
i was having the same problem only when i connected from a Linux or another Mac OS X machine. I used MacSSH on a 9.1 machine and everything worked. I don't know what the difference is though.
 

slur

Geek / Hedonist
The difference is the SSH client's support for SSH 2. The version that shipped with MacOS X is out of date and has problems with SSH 2. You can still get it to connect by using the -1 (dash one) flag, as in:

SSH -1 -l username server.domain.tld

The SSH update linked above will fix the problem with an updated version of SSH. The Web sharing Update 1.0 just posted the other day by Apple also fixes the issue.
 

Digimatt

Registered
The link above works great.

If you do force SSH 1, I could only get it to work this way:

ssh -l username -1 your.domain.com

ssh -1 -l username your.domain.com gave me an error
 

Jadey

sosumi
I've ran across quite a few people discussing this. Switching to SSH 1 isn't the best idea. You can still use SSH 2, but specify the encryption type like this:

ssh -c 3des -l username your.host.com

des and blowfish are both encryption types you may be connecting to.
 
Top