stange: icons keep jumping in the dock but nothing happens!

kemistry

Registered
Hi,

sometimes when I start an application it jumps in the dock forever and finally doesn't start. The Finder kind of freezes (beachball) and no force quit is possible. Just reseting works.
Anyone any idea?
 

kemistry

Registered
I think I solved it. I think it had something to do with the iTunes2 installer. I downloaded a beta from carracho. After installing I was expieriencing those problems from time to time, but did't link it to iTunes yet. Before I installed iTunes2 I never had this. In the last days it got worse, virtually every 2nd app would jump and crash my system. After reading the iTunes instaqller probs I downloaded 2.0.1 and installed it. The optimization prozedure took a very long time, but it seems that the problems are gone now. And the applications are starting up faster now.

thanks anyway.
 

JaViS

Registered
I have the same problems... Just funny that it is only Carbon apps that won't start... ie ICQ and Dragthing won't start but the terminal app and all other cocoa apps work normally...
And the trick with command+s during boot (single user mode) and the fsck -y command make the carbon apps work again... Strange :p
 

BMarsh

Registered
Someone else's TiPB was have problems launching several apps had me look at it, I checked out MacOSX.com and found this thread

I re-installed iTunes 2 (2.0.1) on the TiPB, after the long optimization process, and restart, his system was acting completely normally.

I noticed while testing, that the apps failing to properly launch were limited to carbon apps, and they were listed in Top, and the process viewer
in top, each app that failed to launch would use about 900K of ram
all affected apps could not be quit, or force quit, this would even cause the computer to give an error message when you try to restart from the apple menu

the only solution to forcing it to restart was to use process viewer (or terminal) to force quit the window manager, which drops you to the login screen, where you can click on the restart button, which successfully for me, made the TiPB finally restart

thanks to the previous posters, for allowing me to do a quick and easy fix =)
 

BMarsh

Registered
so much for my earlier post... at least on this particular Titanium PowerBook G4 (500 Mhz) the problem keeps re-occuring

when the carbon apps stop launching properly, he can run the iTunes 2.0.1 installer, and things will work again, for a day or two, then it breaks again

next time it happens I'm going to try the fsck fix and see if that is a longer lasting solution
 
Top