Startup Disk control panel crashes

Hobeaux

Registered
help!

I booted up into OS X and then went to the system controls window to set my OS preference back to 9. when i clicked on the Startup Disk icon, the machine locked up completely.

I rebooted and tried again several time, but it did the same thing each time. I rebooted with Extensions off in Classic and now when I click on the Startup Disk icon, the whole window closes/crashes.

How do i go back to OS 9 now?? i can't set my preference so i have no way of telling it what i want.

tried to use the Startup Disk control panel in the OS 9 directory, but i get a message that I cannot open that when running X

:mad:
 

J5

certified wanker
Turn your sound all the way up, or at least make sure it's on and you can hear the startup sound. Restart with com-opt-p-r held down-
It will make the startup sound, and then the screen goes black, and it will make the sound again.
Now you can let go of the keys.

Try to change the system disk now. Let me know if it works.
 

jmenoche

Registered
I had the same problem, rev.1 B&W G3. I read the posts, and tried several options, nothing worked. I eventually had to reinstall OS X, and now it is fine. Also, I would recommend copying the System Disk utility from the OS X CD to the desktop in OS 9 when you get it running (recommendation from someone else on these boards). That will alow you to go back to OS X when you want to.

Good Luck

PS As a note, when I was finally able to get back to OS 9, I found that my email and TCP/IP settings were hosed and I had to enter them again. I had to point Outlook Express back at my non-standard mail folder location.
 

Hobeaux

Registered
I located and rebooted with a OS 9 CD then set the control panel. was having serious drive issues (which i think is Norton Utilities' fault) and wound up downloading the latest version of Tech Tool Deluxe to repair the machine. all seems fixed accept for the boot block -- disk first aid is claiming that it has errors, but is unable to fix it.

i haven't tried going back into X yet, though. will try that again on Monday when i go back to work.

thanks

BTW: I personally believe that Norton Utilities is responsible for almost all of my drive problems that i've had since i received the machine.

twice i was having B-Tree problems, and both times norton made it half-way through the repair process when the error message "norton detected an error it cannot repair" came up. Norton aborted the process, leaving my drive unmounted and inaccessable. i had to reformat my machine both times to get it back.

the latest problem (hense this thread), norton file saver would freak out when attempting to load in Classic. it would crash itself out each time--i think it seriously screwed something up.

--
Norton Hater.
 

jmenoche

Registered
I hate to pontificate, but well...

I've been fixing/installing/working on PC's for about 12 years, and I can tell you, Norton Utilities is one of the best utilities out there for that (the old Norton Commander, and in particular the Hex editor, has to go down in history as one of the greatest utilities ever ).

Now, that said, stay away from Norton for Mac, it's about as bad as a port of VMS on TRS/80. Techtool Pro, while it lacks the slick interface that Norton has, has it where it counts, in the meat of the program. They also have the Mac experience. My advice, completely uninstall Norton and start using TechTool Pro.

Take Care,
John
 

kelly_hirano

Registered
Originally posted by J5
Turn your sound all the way up, or at least make sure it's on and you can hear the startup sound. Restart with com-opt-p-r held down-
It will make the startup sound, and then the screen goes black, and it will make the sound again.
Now you can let go of the keys.

Try to change the system disk now. Let me know if it works.
that didn't work for me. my problem with the startup disk control panel was a little different, though. when i select the icon in the system preferences pane, my disk spins for a few seconds, then the application unexpectedly quits.

anyone else have this problem or know if a solution?

thanks.
 

Hobeaux

Registered
Yeah, that's the same thing that I encountered. I used an OS 09 boot CD to get back to 9 then used the control panel in the OS 9 directory to make sure i didn't go back to X.

I used Tech Tool Deluxe to diagnose and repair my drive but I haven't been back to X yet to see if things are working better.

In the Applications/Utilities (i think) is a new version of
Disk First Aid -- it may help.

I left my copy of the 9 boot CD at home :( so i haven't tried going back into X yet. I'll post back here tomorrow when I see if it works properly now.
 

kelly_hirano

Registered
thanks for the tip. haven't booted into os 9 yet, but i did run the disk utility. it noticed an invalid b-tree header, 0, , but i can't repair it. i'm guess it's because i'm running disk utility off the disk i'm checking or because it's the startup disk. i tried booting off the os x disk, but couldn't. os x wasn't even recognized when i inserted the cd rom after i booted. i'm running on a powerbook g3/400 bronze. i realize hot-swapping isn't supported, so i shut down, then put in the dvd-rom drive, and tried what i said above.

thanks.
 

Hobeaux

Registered
Okay, I brought my boot disk into work and then bravely booted back into X and promptly went to the Startup Disk system preference.

I clicked and it works! all fixed now, thanks to Tech Tool.

 

isdigital

Registered
Hi Folks,

Thanks for all the messages. Apple has a real problem on their hands with this Startup Disk business (aka, B-Tree header error 0,0).

My jaunt with this started with the OS X (PB) version of Startup Disk crashing the Preferences panel app. as described above. I went to the Disk utility and ran that to find errors on almost all of my partitions. Those on the OS X boot volume couldn't be fixed, of course. So I booted into single mode and ran "fsck -y", and, yup, the errors were there, were fixed and were reported as gone when I reran fsck. Back in OS X, the Disk utility reports that the error is _still_ there, and I'm not surprised when the OS X Startup Disk panel continues to crash the Preferences app.

After Alsoft Diskwarrior (2.0.2), Tech Tool Pro (3.0.2), and Norton DD (5.0.4), in that order, my fears are confirmed, and I must wipe the partition and start anew. (This was after less invasive things suggested elsewhere, like resetting PRAM, and power manager reset.)

If anybody has any tips on what went wrong in the first place, I'd love to hear about it. (As well as what Apple plans to do with OS X on these bronze PowerBooks, if anybody knows ...) I was moving pretty fast on the OS all day, including installing the developer tools, (why doesn't it install the man pages?). I had a problem with the trash at one point, where it wouldn't empty. I emptied some .Trash paths by hand, ... probably a no-no, but the system worked fine for hours afterwards.
 
Top