startup problems

aengus

Registered
Hi

My daughter's G4 Ibook began to misbehave by shutting down suddenly, now it is not starting up. Mum can normally sort this out, but I am running out of ideas.
We have tried to use the discs but starting up with C or D held down has no effect. I have used the firewire and held T down to allow me to use disc utility from my machine and on one it claims that there are no problems- no verify or repair is necessary. On prior occasions it has been unable to mount the drive, or has reported problems, but not recently. Once I managed to use the disc in her machine through the firewire from my machine- and it failed to work. subsequent attempts have also failed (because my machine is a later one, having a different base system and wont entertain the old one.)
I have tried to eject the startup disc, both by using f12 and by holding down the 'click' on startup- to no avail. I have been trying to use other startup discs from inside my MacBook.
This evening we tried the 'apple' and 'S' and got the following messages mingled in with a general rant:-



Failed to load extension com.apple.bootCache.

Failed to load extension com.apple.iokit.IOHIDFamily.

And….. com.apple.iokit.IONetworkingFamily.
Couldn’t alloc class com_apple_bootCache
IOBSDConsole
IOHIDSystem
IONetworkStack
Still waiting for root device (repeated)

the still waiting for root device is ad infinatum - so we can't get the prompt to make any progress.


More bizzare...I think it is a power based problem because...

if the battery is allowed to go totally flat the machine will start up normally all on its own, but will soon start playing up and shutting down for no reason.

the little light around the power cable is always green when the machine is switched on, and reverts to orange when power is switched off. It is only normally green either when first connected to the mains, or when fully charged so i don't think it is reading properly.

The RAM card looks ok.
There is no 'foreign' hardware connected.
I am stumped. can anyone offer some guidance?
thanks

MAY be relevant
Prior to the problems:-
we took the laptop abroad
it was x rayed at an airport.
it was charged up on 'foreign' electricity that might have had different volts and stuff.
 

VirtualTracy

Thunderbirds are GO!
I have tried to eject the startup disc, both by using f12 and by holding down the 'click' on startup- to no avail.

Not sure if I understood correctly but try this:

  • Restart the computer and hold down Command + Option + O + F
  • At the command prompt, type: eject cd
  • The disk drive will eject.
  • Restart the computer and hold down Command + Option + P + R
 

rubaiyat

Registered
The X-Ray and foreign power supply have no effect. The Mac adjusts automatically to different voltages and hertz and the X-Rays are too weak to do damage, or you'd have everyone suing the airlines!

You have not said what system you are running nor whether this after some upgrade or installation.

Do you have en external HardDrive, preferably FireWire or bootable USB, that you can install a system onto and boot from there?

It sounds like it may be a software rather than hardware problem, zapping the PRAM & NVRAM with Command + Option + P + R at least 2 times after start up (ie on startup hold down the keys and wait till the Mac does its deep chime, then again a second time). If you never switched the small internal lithium battery on the G4 (the one to hold your PRAM, not to power the Mac) I think now would be a good time. They are only good for 3-5 years and hold you settings and startup information, the "PRAM".

If you recently upgraded to Leopard be aware that it has caused numerous problems on older pre Intel Mac's hard drives. My iMac G5 is one of those. All we can do is await OSX 10.5.3 and hope Apple has fixed it.
 
Top