Stop iPhoto from Copying Files



First post.

I switched from Windows XP to Mac OS X last week and I'm very pleased with the decision. I'm running OS X 10.4.1 on a 12-inch iBook G4. When I imported all of my music, I noticed iTunes making copies of the MP3 files in its own "iTunes Music" folder, and this was quite frustrating as I have a small hard drive and I didn't have much space to spare. After I had changed the preferences and gotten iTunes working the way I wanted it to, I began working on iPhoto collections... and again, it copies the photos to a designated "iPhoto Library" folder. So I went into iPhoto preferences and I didn't see any option to stop it from copying the image files. Now, I've got about a gig and a half of photos... and currently, 3.8 GB of free space on the hard drive. Importing these into iPhoto, and there having them copied, would leave me with a dangerously low amount of free space. Is there any way for iPhoto to not copy these images into its special folder, and just leave them where they are and read them from there?
If you don't want the two copies of files, you are free to delete the originals. Better yet, archive the originals to CD or DVD and then delete them from your hard drive.
Deleting the originals occured to me, but I like to have the files in their original folders with their original file names, etc. So there's basically no way to stop iPhoto from copying?
iPhoto catalogs files according to their creation dates. You cannot change this. Using iPhoto is a choice. Wanting only one copy of each photo image file is a preference. Not wanting to delete the original is a fear. Getting everything you want is unlikely. Getting it without work is impossible.

There is nothing to stop you from preserving your original folders, file names, etc. As I said in my previous post, you are free to archive your photos to CD or DVD. This is standard practice for preserving essential files. In fact, they are safer on CD than they are on your hard drive.

The choice is yours.
In iTunes, open "Preferences" - "Advanced"

uncheck "Copy files to iTunes music folder when adding to library"