Strange Keyboard Key Behaviour


Dear All,

I have a MacBook Pro 13" MID 2012 (MacBookPro 9,2) running on 10.9.5 with 4 Gig of RAM.

Recently the integrated mouse pad started to go crazy, possibly although not sure because of liquid. In the process it fried the Hard drive for some reason.

So I opened it, cleaned the mouse pad in alcohol, put it back changed the HDD and it started working fine again. Unfortunately in the process the PAD go hit and cracked in the corner. It still worked, but didn't look nice. So, bought a new track pad and replaced it. It works perfectly fine. So all good on that side.

But... something strange then happened, even before I replaced the pad. The keys F11, F12, Disk eject and backspace stopped working... All the other keys work perfectly. When I changed the track pad, they still didn't work, but after 5 minutes or so they suddenly worked again. I turned the computer off and when I turned it back on, they were not working anymore and never came back to life since. When I use the Keyboard viewer, they do not react either.

Now here comes the very very strange bit. If I combine them, that is if I press them all at the same time, they do react... backspace+eject+F12 gives me the apostrophe and shows on the Keyborad viewer as such. eject+F12+F11 gives me the inverted commas and again shows as such on the Keyboard viewer. eject+F12+F11+eject gives me both the inverted commas and the apostrophe and again shows as such on the Keyboard viewer. If I try these combinations on a computer that doesn't have that problem, these combinations give nothing...

Any other combination of these keys do not give anything. Also to test if each key was actually recognised, I pressed both combination varying which was the last key pressed, and they all seem to be picked up, which seems to indicate that they all work.

I did a fresh install of Mavericks, nothing. I cleared the VRam, nothing.

I tried to disconnect the mouse pad altogether and start the computer, and then to my surprise the whole keyboard is not recognised anymore, indicating that somehow keyboard and trackpad are related. When I connected it again, the keyboard worked but those 4 keys still not.

Any ideas as to what I could do? I can live without the F and eject keys, but not having the backspace is really a pain.

Thank you all !
A thought: there is residual liquid on the board at the spot of those keys. i.e. - soda when dried leaves a sugar residue that you can’t see. Use 91% alcohol to clean the board, let it air dry, then give it a try.
I'd suspect the 'possible' liquid spill getting in the keyboard also. After this length of time, you may have to replace it.
Only other possibility would be if, in your repairs, you disconnected the keyboard ribbon connector and then reconnected it. They can be a bear to get back in straight & tight.
Hi guys, thanks for teh advice.

The alcohol did fix the mouse pad problem initially, so I am keen to try on the keyboard as well. But from where? Can I pop the individual keys off from the top, or do I need to get underneath ? Underneath is quite a mission because that would basically mean stripping the whole computer apart and I'm not quite comfortable with the idea...

SGilbert, I did not understand "They can be a bear to get back in straight & tight." Also, I have not seen the keyboard ribbon, where is it? I don't believe I touched it. That being said, when I tried to see if the problem was coming from the track pad, I disconnected the pad's connector, and then started the computer. To my great surprise, it then told me that there was no keyboard connected. So somehow, the pad connector is involved with the keyboard.
I suggest you clean under the individual keys And underneath the board. You should be able to lift the board without disconnecting the ribbon cable.