Stuck trackpad button on iBook G4


so after owning laptops from as far back as a PB140 I finally did the worst (besides dropping my Pismo & cracking the screen)....

I spilled on the keyboard....and not just water....nope...a goodly bottle of green tea (with ginseng & honey, of course)

immediately powered down & pulled the battery....actually, i just yanked everything....pulled keyboard & AP card, dried everything I could see (even in the RAM slot under the AP card)....blew a hair drier thru it....did whatever I could without going thru wht looks to be a MAJOR thing...a cover removal

so after letting it sit overnite, I cross my fingers & fire itup....yay! it boots!


the trackpad button seems to be stuck DOWN....if I'm on the desktop, it draws slecting boxes, if I'm on a web page it selects everything it touches....SOMETIMES I'm able to mash ESC to release it, but it kinda auto-selects again....basically I can't navigate very well at all....I SOMETIMES get SOME response to the button if I really mash it, but that also sux

tried an external trackball, but on IT the left button don't respond at all

I guess I killed it, but I was wondering if there was a way to disable the machine seeing the built-in trackpad & button & just use a USB something until I can get this repaired by someone more brave than I....tried setting the trackpad to detect a tap as a button press but that does nothing....the machine just sees the mouse button down all the time...