Stupid ? - Apple Talk / Mounting drives

Fahrvergnuugen

I am the law!
I have a G4 which accesses the Internet via modem. It's also connected to a hub which has my G3 on it. Both Computers are running 10.0.3. The G3 has only the ethernet interface enabled. The G4 has both modem and ethernet with modem taking precedence over ethernet.

When I Command-K [connect to server from finder], neither computer sees the other one on the network. If I open a new finder window and click the Network Icon next to the disk icons, only the local machine shows up.

I can ftp between the two computers, but it takes it longer than I would have expected to prompt for a Username. [It says connected to 192.168.0.1.... then 40 seconds later it asks for my login/pass]. Pinging between the two machines works fine, 100% < 10ms

Am I doing something wrong? How do I mount the drives properly?
 

Red Phoenix

Registered
I have posted the reason for the long delay before, and hoped that someone would say something about how to fix it. It involves editing the NetInfo database.

First, I'll state the problem: the FTP server tries to look up the name of the computer connecting, but since it's on a local network, there is of course none. On a normal UNIX machine (I believe), you could solve this by editing the file /etc/hosts and adding a line such as "192.168.0.1 this.is.a.bogus.address.mil". However, Apple uses the NetInfo database which I don't really understand. However, try this (but don't blame me if something screws up. You have been warned.):

Open up "NetInfo Manager" in the Utilities folder. Click the lock to make changes. Then, go to "/machines/" and select "localhost". Now select "Duplicate" in the "Edit" menu. Select your new duplicated file, and the properties will appear on the bottom. Change the ip_address entry's value to "192.168.0.1" or the other computer is on the network. Then give the name a value of something like "trix.are.for.kids.co.uk". That should be it. Save the work, and either reboot or select "Restart All NetInfo Domains on Local Host" from the "Options" menu of NetInfo Manager, and quit.

The reason why I am not sure about this, though, is the "serves" entry. I have no idea if this needs to be changed, and if so, to what. My best guess it to leave it alone. Also, you should always be wary of doing anything with the NetInfo Manager. Most of the stories I have heard of people having to reinstall OS X seem to involve screwing something up with NetInfo. On the plus side, I honestly can't see how this would cause too much of a problem. If this doesn't fix anything, though, I would immediately delete the new work. However, I believe it will work.
 
Top