Suddendenly Non-mounting Volume On External Drive


So I buy this acomdata 160GB firewire/usb external drive for my g4 12" powerbook(1.33GHz) running x3.9 and i'm in memory heaven using just the usb 2.0. So to get better performance I buy a retractable firewire cable and it's super slow. So i go back and forth from the usb and the firewire to verify this (i'm careful to eject disk and not plug 'em both in at the same time). Still, the system freezes, and I nervously shut down the computer manually drive still mounted. Restart everything but the drive's not showing up in the finder or desktop with either usb or firewire as it should. However, it does show up in Disk Utility. At this point:
> Disk Utility repairs on HD and external drive and it's non-mounting volume. Manual mounting from disk utility also unsuccessful
> iPartition to partition the drive (no logic as to why i did this, but partitioning allowed for the new volume to show up, mount and be accessible. The old volume/partition with 20GB of hard work still won't mount)

I've tried to be detailed. I'm comfortable with this computer stuff but am no expert. haven't worked much in terminal but I'm willing to give it a go as there's only one large iMovie file i need to pull out of this non-mounting partition -- after that i'd format the f#@%er.
I also am having problems with a 160 gb acomdata drive i bought maybe two month's ago from fry's. suddenly, it simply didn't mount. disk utility wouldn't verify it/repair it. Luckily, attaching it to an XP machine (*gasp!*) at work mounted it and i was able to get all the data off of it.

brought it back to my pb to erase/re-format it, and again it didnt' mount. it appears in disk utility, but it says that my drive is 918.5gb!!! erasing it doesn't help.

someone please help (us)!!