SUPERDRIVE Doesn't Work - Help!



I have a Powerbook G4, 1GHZ, 1GB, 60GB, Superdrive.
Since I bought it in November 2002 I have been running 10.2.1

I recently did the Combo update to 10.2.8.

Now the Superdrive doesn't work properly. Problems include, not loading discs, not ejecting discs, etc. I have a dual boot system and tried it in OS 9 it seemed to work okay.

I have tried all the other options such as resetting PRAM etc.

Is there anyone who could help?

Many Thanks
Pavan :(

Thanks. I found the link a coupe of days ago too, but am unsure whether or not I should do it. I read somewhere in the page that if the firmware doesn't install properly then the drive would be completely useless.

Any experiences?

Many Thanks

I think we are using the same systems. It worked fine for me and I have it installed for at least one year. I don't want to push you into something here, but I find it quite safe. The warnings mentioned on the site are rather standard than exceptional when it comes to firmware-upgrades.
Well, at least it is a solution, and for that. I am grateful.

I might also try upgrading to 10.4 first, as a friend of mine recently told me that 10.2.8 is very unstable.

Either way I will keep you updated.