System Preferences Won't Launch

yaomi

Registered
I have OS 10.3.9. I have downloaded some Word doc and PDF files in the past two weeks. Also I installed HP driver and FlySketch ( a screen catpure utility). I didn't use SP until earlier today and nothing happened when I clicked on SP. When I went to the display icon and clicked "Display Preference," I got the "Displays.prefPane" with a content folder. I have used Disk Utility and it fixed a bunch of permissions. Yet, there is no sight of System preferences.
Error message I got from console is: "Mac OS X Version 10.3.9 (Build 7W98)
2005-08-13 15:57:01 +0200
I'm in the main function
diagappDialogBase::setProperty( "sizeGripEnabled", value ) failed: property invalid, read-only or does not exist
i've been in stUsb constructor"
Log from Disk Utility
Determining correct file permissions.
We are using special permissions for the file or directory ./Library/ColorSync/Profiles/Displays. New permissions are 16893
We are using special permissions for the file or directory ./Library/ColorSync/Profiles. New permissions are 16893
We are using special permissions for the file or directory ./System/Library/Filesystems/cd9660.fs/cd9660.util. New permissions are 33261
We are using a special uid for the file or directory ./private/var/at/jobs. New uid is 1
We are using a special uid for the file or directory ./private/var/at/spool. New uid is 1
The privileges have been verified or repaired on the selected volume

Permissions repair complete
Please HELP!!
 

barhar

Registered
'... nothing happened when I clicked on SP ...', - Are you attempting to say 'I selected the 'Apple, System Preferences...' menu item? Yes, or No. If no, then exactly where (provide the full path) is the 'System Preferences', SP, you clicked on?

Did you locate, open, and actually look in the 'Applications' folder for 'System Preferences'? This is where SP should be. Do you see SP in the folder?, Yes or No.
If not, do a 'Find' ('Finder' 'File, Find...' menu item or 'Command F') and search for 'System Preferences'.

'... I went to the display icon and clicked "Display Preference ...'; exactly where (provide the full path) is the 'Display Preference' you clicked on?

'... I got the "Displays.prefPane" with a content folder ...'. To obtain the 'Diskplays.prefPane' window, one must click once on 'Displays.prefPane' ('/System/Library/PreferencePanes/' - notice, the file's full path) and via a contextual menu (right button click, or <option> click) select 'Show Package Contents'. Is that you did?

---
Obtaining SP from ones 'Panther' 'Mac OS X Install Disc 1' disc:

SP can be extracted (via the 'Archive.pax.gz' file) from the 'Mac OS X Install Disc 1/System/Installation/Packages/Essentials.pkg' package file.

Do the following:
01. Insert the 'Panther' 'Mac OS X Install Disc 1' disc.
02. Launch 'Terminal' ('/Applications/Utilities/' folder).
03. Copy the next line of text (yes, it appears as multiple lines; but, it is a single line of text)...

mkdir ~/Desktop/temp_SP; cp /Volumes/Mac\ OS\ X\ Install\ Disc\ 1/System/Installation/Packages/Essentials.pkg/Contents/Archive.pax.gz ~/Desktop/temp_SP/Archive.pax.gz; open ~/Desktop/temp_SP

... and paste it into the 'Terminal' window, press the <return> key, and wait as the 201.3 MB 'Archive.pax.gz' file is saved to the folder 'temp_SP' created on your 'Desktop'.
Once the 'temp_SP' folder opens, double click on 'Archive.pax.gz' and wait for the file to decompress - creating a file titled 'Archive.pax' (456.4 MB in size) and a folder titled 'Archive'.

In the 'Archive' folder are folders, one of which is 'Applications'.
Open the 'Applications' folder of the 'Archive' folder, and open your hard disk drive's 'Applications' folder. Drag the 'System Preferences' application from the '.../Archive/Applications/' folder to your hard disk drive's '/Applications/' folder.
Double click on your (newly installed) '/Applications/' 'System Preferences' application. Does it launch? Yes, or No? (it should)

Locate the 'temp_SP' folder on your 'Desktop', trash it, and empty the trash. You can also eject the 'Mac OS X Install Disc 1' disc, and quit 'Terminal'.

P.S. The newly installed 'System Preferences' application should have the proper permissions automatically set; thus, no need for one to (have to) perform a 'Disk Utility' 'Repair Disk Permissions'.
 

yaomi

Registered
I did click on the SP under Apple, nothing happened. I have gotten a copy of System Preferences from the cd and it is in the application folder. Now it will open ONLY when I click on it from the application folder. It still refuses to open under Apple menu. I can't explain why this is. Someone told me this might indicate that the HD's integrity might be questionable. I should do a backup and reformat my HD. Does this mean I am having a severe problem with the HD?
 

fryke

Moderator
Staff member
Mod
If you took SysPrefs from the CD, that might be an older version than your system (if that's been updated). So you have to at least run the latest combo updater again.
 

yaomi

Registered
I have done the update and it still doesn't launch from Apple menu. Just can't figure it out why that is.
 

barhar

Registered
Here (on my various internal hard disk drives, HDD, and firewire based HDD), my copies of MacOS X 10.3.0 and 10.3.4 use 'System Preferences', SP, v. 2.2; and, MacOS X 10.3.8 and 10.3.9 use SP v. 2.3.

I '.zip'ed the SP (v. 3.1) of MacOS X 10.4.0 and 10.4.2 (each), and use v. 2.2 (in each respective 'Applications' folder) instead. This way I once again have the toolbar feature (removed by 'Tiger's version of SP).

As far as the 'Apple, System Preferences...' menu item not launching SP. I will see if I can find something ...
 

barhar

Registered
You know, for the heck of it - reboot your Mac and go into 'Single User' mode.

Press and keep pressed the 'Command S' keys during the boot process, enter

fsck -fy

... and press the <return> key. If all goes well, enter

reboot

... and press the <return> key.
 

barhar

Registered
With respect to 'does this mean I am having a severe problem with the HD?', I doubt it. Somehow, MacOS X hiccup'ed and you have loss some functionality.

Unfortunately, you may have to go the Windoze route (now, all too familiar with MacOS X), as someone told you, and backup your data and reinstall MacOS X - erasing the drive during the re-installation process, and then install all the related updates.
 

LovesMacs

Registered
Just for kicks have you tried trashing the "com.apple.systempreferences.plist?
If you haven't already done so it sure can't hurt to try.

Macintosh HD>User>Library>Preferences>com.apple.systempreferences.plist
Drag the com.apple.systempreferences.plist file to the Trash. Reboot your Mac.
See if that helps.
 

barhar

Registered
After trying Carolyn's (LovesMacs) suggestion. Should you have the same results ...

Launch 'System Preferences', SP, (from the '/Applictions/' folder), create a new user account via the 'Accounts' Utility (allowing the new user to administer the computer), and quit SP.
Log into the new account, try launching SP via the 'Apple' menu; and, report your results.
 

crashish

Registered
I am having approximately the same problem. I have trashed the systempreferences.plist and the preferencepanes.cache as well as run the permissions repair utility. I am running 10.3.9 and the System Preferences will not open from the Apple menu, but will open just fine from Finder and the Dock. I have also tried adding a new user with full admin access and can stlil not open SP from the apple menu.

Anyone have any ideas?
 
Top