TCP quits in classic mode

dtempleton

Registered
Setup: G4 DP, ethernet netork, campus DHCP server, etc.

Web off, Filesharing off. (have tried on too).

DHCP on in Network. DNS Servers specified manually (but automatic setting seems the same).


Starting up OSX + classic, classic apps (Eudora, EIMS mailserver) can find the DNS Servers and fetch and send mail. Classic Explorer works too. ***BUT TCP STOPS WORKING WITHIN 3 MINUTES*** Sometimes 30 seconds.


Carbon Explorer and Mail work fine, both immediately and long term.

Re-logging in as admin restores classic function.

??unrelated, classic won't restart from menue. if force quit, won't restart if classic app is launched)??

Really need too have my mailserver running, and haven't configured sendmail (yet)

Thanks
 

dtempleton

Registered
Trashing the TCP pref didn't work (The TCP pref file was not restored). Nor did replacing it with a copy from a working sys folder.

The TIL says it is a problem mostly with BootP servers, Mine is a DHCP.

I have tried: No OXC networking, BootB and DHCP, all manual setting.

In classic, Explorer will mount a page if the address is given as a dotted ip address, but not a name, so it seems to be an issue with accessing the NameServer.

:=/

 

gtb

Registered
I'm also experiencing this problem. Shortly after starting classic and running a classic app that needs to use DNS, DNS hangs. Sometimes it clears up, sometimes not. I have also tried the recommended fix of deleting my tcp/ip preferences and resetting them with a manual setting. This did not fix the problem.

I do find that if I go into the appletalk control panel and toggle back and forth between active and inactive this seems to wake DNS up again. But not every time.

DNS works fine under OSX, just not classic.

-gtb
 
Top