tcpdump: no suitable device found



I tried to use TCPDUMP and this is the error message I got "tcpdump: no suitable device found".
What is going on??
How do I fix this??
I tried installing TCPFLOW ( and it installed fine but i got the same error when trying to use it.
I checked my interface (ifconfig) and it has an IP (it works on the internet as you can see) and the interface is up.
And YES I am logged in as root when I try using TCPDUMP.
OK so my response was that you needed to be root, then I read your post and you said you were root. So now I have no clue why you would be getting this error. I only get it if I'm not root. My only thought is that maybe your permissions are all screwed up somewhere, but nothin justifies the lack of read access for root. ... good luck.
One simple thing is to doublecheck that the device it's trying
to open is correct. It may have been hard compiled w/ an incorrect

They're different on every unix system (eth0, le0, en0, .......).
On my Lombard, it's en0
As howardm4 pointed to, you need to specifically state a device; the following works fine for me (remove sudo of course, if you're already root):

sudo tcpdump -i en0