Terminal and keyboard...

Kristjan

Different, I think...
Hello...

Is there any way to change the keyboard mapping in the terminal (and BitchX) so that I can use swedish characters (åäö)?

When I'm in the terminal I can't even type any swedish characters. In BitchX I can atleast type them, but they don't look right to the people I'm talking to. "ÅÄÖ" becomes something like "-*,".

Thanks!
 

ronald

Registered
Well this is not an answer to your question, I'm just taking it a bit further. When using vim vi or egrep from the CLI, the system can't find some characters like ^ ~ when my keyboard is set to danish. So i have to toggle the keyboard settings back to US an play cath with these characters ( the carret ^ f.ex. is shift & on a danish keyboard ).
 

Kristjan

Different, I think...
My *nix friends told me to change my keymap in a program called Kbd. This program isn't installed in Darwin, so I tried to compile it myself. When I run configure I get an error though. Like this:

-
[localhost:/Users/kristjan/kbd-1.06] root# ./configure
Configuring for DATADIR=/usr/share/kbd
Configuring for MANDIR=/usr/share/man
checking for gcc
gcc not found
You have <locale.h>
You don't have <libintl.> and gettext()
[localhost:/Users/kristjan/kbd-1.06] root#
-

What is 'libintl.h', 'gcc' and 'gettext()'? And how do I install them?

Thanks...
 

finnboo

Registered
<p>As far as I know the current version of the Terminal doesn't support any characters that aren't in the basic ASCII table. Therefore special regional characters, such as the swedish characters and the icelandic &thorn;, &aelig; and &eth; etc. won't work.
 

endian

Dis Member
What is 'libintl.h', 'gcc' and 'gettext()'? And how do I install them?
You probably just need to install the Developer Tools CD that came with your copy of OSX. gcc is the c compiler, and the others are probably from supporting libararies that go along with it.

You shouldn't need to be doing it as root either. You can run configure and make as yourself, then just do a sudo make install if required to get everything where it needs to be.
 

Kristjan

Different, I think...
Endian: No, that's not it. I have installed the Developer Tools CD.

Perhaps gcc and the other files are in the wrong place, or something?

And what about what Finnboo tells us? That there is no way to get to get 'regional characters' working in Terminal. Can someone confirm this?

Thanks for the replies anyway. :)
 

Kristjan

Different, I think...
Symlink? Hehe, you lost me. I'm a *nix newbie, :). Like an alias in Mac OS 9? How do I do this? And what about 'libintl.h' and the other file? Can 'symlink' these aswell? Do you know anything about that?
 

AdmiralAK

Simply Daemonic
symlink is a symbolic link I think. Its like an alias in classic MacOS
 

Kristjan

Different, I think...
Ok! Can someone tell me how to make a symlink then? I tried searching for files called 'cc" and 'gcc' with Sherlock, but I didn't find any...

And oh... Did I mention I'm a *nix newbie? :p
 
Top