terminal

Ondrej

Registered
Process completed is reported when i try to open up a terminal - i can't determine what process, and I don't ever get the option to go to the prompt - any ideas anyone? console does not appear to be of any use! Thanks!
 

endian

Dis Member
i get this too, what it means is your shell is screwed somehow.. try entering 'sh' without the quotes in the execute terminal command dialog of terminal.app.. that was the only shell i could get to work. i'll work on it more after i get home.. maybe copying tcsh and csh off the CD would fix it
 

Ondrej

Registered
Thanks - I actually posted this in the troubleshooting section as well. However it appears to have happenned to a few people. zsh works as a shell as well as just sh. I'm not sure anymore, but i think at one point when I did an ls -l, I found the file sizes of tcsh and a few other files in the same directory to be 0 bytes long ..... not good I think. I think I tried copying tcsh over, but that didn't work. Suspect there was something in the config file ?.tcsh? which was being loaded and also didn't work. Ended up reinstalling the system - but PLEASE let me know what you find out.

Note: Reinstalling the system was dangerous - after reinstall, it recognised all of the users, but NON of them were superuser anymore, and i could NOT login as root. ie - no superuser or root access. All user had been turned into useless drones! :)

Best of luck.
 

endian

Dis Member
i ended up just starting fresh, reformatting as HFS+ and reinstalling. Disk First Aid reported damage, which there is currently no way to fix w/o having another OSX partition - the CD is install-only and DFA can't repair the startup volume.

I tried to install w/o reformatting, but it stopped with "Operation Not Permitted"

*shrugs* oh well, it's a beta...
 
Top