terminfo

hazmat

Rusher of Din
I am trying to set my term to rxvt (or others for that matter) and am having trouble. I downloaded a recent terminfo file and set my TERMINFO to point to it, but still when I set TERM to rxvt, it tells me that it is not recognized; same for other term types. Anyone know what the deal with this is?

Thanks.


-Ken
 

hazmat

Rusher of Din
Originally posted by jimr
maybe in XFree86.

At this moment I am not aware of a replacement for Terminal.app.
No, sorry, I meant just the term type set in Terminal. Default is vt100, but I would like rxvt.


-Ken
 

jimr

McInstigator
Terminal names (except for the last, verbose entry) should
be chosen using the following conventions. The particular
piece of hardware making up the terminal should have a
root name, thus ``hp2621''. This name should not contain
hyphens. Modes that the hardware can be in, or user pref-
erences, should be indicated by appending a hyphen and a
mode suffix. Thus, a vt100 in 132 column mode would be
vt100-w. The following suffixes should be used where pos-
sible:

center ; l c l l l l. Suffix Meaning Example
-nn Number of lines on the screen aaa-60 -np Number
of pages of memory c100-4p -am With automargins (usu-
ally the default) vt100-am -m Mono mode; suppress
color ansi-m -mc Magic cookie; spaces when
highlighting wy30-mc -na No arrow keys (leave them in
local) c100-na -nam Without automatic margins
vt100-nam -nl No status line
att4415-nl -ns No status line


hp2626-ns -rv Reverse video
c100-rv -s Enable status line vt100-s
-vb Use visible bell instead of beep wy370-vb
-w Wide mode (> 80 columns, usually 132) vt100-w
ADM-3.........................................etc.
For more on terminal naming conventions, see the term(7)
manual page.


so you see, terminals are based on some old pieces of hardware.

the terminal emulation programs are eterm, xterm, rvxt, nerm, gterm on GNU (freeX86)

and MacOSX has terminal.app

you can figure out what it is that you like on your favorite configuration for rxvt and then you could probably set that up in terminal....

the parameters are the shell (default is tcsh) you can have bash if you get the source and install it.

the TermCap

the emulation

the local environment settings in the start-up scripts.
/etc/csh.cshrc

which points to
/usr/share/init/tcsh/rc

there is a readme in that directory which you should checkout.



if what you really want is color,

the problem is that "ls" is broken

you can find binaries out on the net. or you can download the FileUtils 4.x from sourceforge and replace all of them....

"ls" in that package supports color.

and you may either write a custom corol def and put it in your environment.mine file or you

my just call DIRCOLORS to write a standard list of colors for you.

you still have to make an alias in alias.mine
for ls --> alias ls "ls --color=always -F"

or whatever you like.

otherwise, I like rxvt in X-windows, and Gterm is broken for the time being, but in OSX terminal.app seems to work just fine, unless you need something smarter or dumber than VT100....

anyway, they don't call them "Dumb terminals" for nothing....
 

hazmat

Rusher of Din
Thanks so much for the detailed reply. Basically what I need color for is mutt. I don't care about ls. What I am thinking about with respect to rxvt, and I may be totally off here, is that when I use SecureCRT (or I think through gnome-terminal as well under Solaris), trying different terms changed the way mutt displayed. One big issue is how it interprets where to end the line, as in the end of the terminal or end of all the text on the line. For example, when highlighting text in the mutt pager or vim, it would highlight to the end of the actual terminal, messing up pasting, to say the least. So playing with different term types (setenv TERM) would give different results as far as color and also what I mentioned above. What worked best for me in the end was setting it to rxvt. This is mutt via ssh, so what I was thinking was that even though the remote term (OpenBSD) was set to rxvt, I was wondering if the local Terminal.app not recognizing it would mess things up. With local term set to vt100 and remote to rxvt, I did get color, but things were not formatted properly.

Thanks again.


-Ken
 

howardm4

Registered
well, I have mutt doing exactly what you want.

What I did was obtain and compile ncurses and then compile mutt w/ ncurses.

Then get a good termcap entry and make it your ~/.termcap.

Set your TERM to whatever (xterm-color, rxvt) as defined in your .termcap
and away you go.

I dont think it'll ever work w/ the OSX supplied curses library cause it does
not seem to support color.

I have mutt working in ANSI color but I cant get emacs. My hunch is that
when I recompile emacs to use ncurses 5.2, things will work properly there
too.
 

hazmat

Rusher of Din
Oh, great, thanks. :) I cannot believe it was as easy as getting a termcap file and copying it to ~/.termcap.

But unfortunately this hasn't fixed my problem. From searched I have done, it seems that the Apple Terminal (nsterm) is buggy, and people are anxious for an update, since it seems to have been taken right from NeXT Step. My problem seems more general. First of all, mutt through ssh gets really off formatting, since the remote terminal is set to rxvt. In mutt's index, the selection bar only goes to the end of the text, not the terminal. If I set term to dtterm, the index works as it should, bar to the end of the line, but the pager highlighting is all messed up. More generally, remotely or locally, I can't seem to get it, when highlighting text in vim or whatever else, to only highlight to the end of the text field, not the end of the terminal line. This is bad for copying and pasting.

Any ideas to fix all this, or is this just a limitation right now of the Terminal?


-Ken
 

howardm4

Registered
Like I said, I *think* you need to get ahold of ncurses, build it and
compile mutt w/ it.

It appears to work correctly for me but I may not be fully understanding you.
 

hazmat

Rusher of Din
I installed ncurses a while ago, and mutt was compiled with it on the server. Do you use mutt locally or via ssh/telnet? I am using via ssh. Through SecureCRT in Windows or gnome-terminal in Solaris, things are fine as they are. Connecting from the OS X Terminal to the remote server, when I fire up mutt (remote term is set to rxvt), and it counts the emails in a folder, parts of it are screwn across the bottom of the screen. The mutt index displays okay, sort of, but the message selection bar gets cut off at the end of the text on that line. Changing the term to dtterm, the index looks as it should. With either set, highlighting blocks of text in the mutt pager or vim or wherever will highlight all the way to the right edge of the terminal. It should only go to the end of the text on each line.

Does this make more sense?
 

howardm4

Registered
I was using mutt locally w/ an NFS mounted mailspool file.

I haven't tried using via telnet/ssh back to my OSX box.

I can try that today if I get into the office or remember.
 

hazmat

Rusher of Din
Thanks, I would really appreciate that. All I want to be able to do is use mutt remotely via ssh, where:

- the message selector bar in the index goes to the end of the screen

- selected text in either the mutt pager or vim will only go to the end of each text line, not the screen

- color supported


This all works perfectly in my ssh sessions via SecureCRT in Windows, and I think also in gnome-terminal in Solaris. Though I don't know a lot about terminfo/termcap, everything I have tried has been unsuccessful so far. And I can't figure out if it is just a setting I am not thinking of, or the terminal itself.
 

hazmat

Rusher of Din
I just tried recompiling vim, making sure it was with ncurses, and also built mutt 1.2.5i, both locally. Whether in the mutt pager or vim, highlighting a block of text highlights the entire window, as in all the way to the end of each line to the screen edge, not the end of the actual text. I have tried using vt100, rxvt, and dtterm. All the same result in this respect.
 

skinlayers

Registered
Hello,

I am trying to ssh into my OSX box from work using OpenSSH in Cygwin. When ever I do, after the "Welcome to Darwin" line it says something to the effect of "Terminal type 'cygwin' not recognized, using dumb terminal settings". So, I am unable to use cursor key (my major concern). Most of the time I get around this by running VNC and remotely launching Terminal.app via the GUI. For some reason the cursor keys don't seem to function in certain programs (like Terminal.app). Any suggestion on how I can add an entry for cygwin to that my cursor keys are enabled when SSHing?

Thanks,
Skinlayers
 

hazmat

Rusher of Din
set term=vt100

That's for tcsh. I forget what the bash one is, in case that's what cygwin is using. If I were you, I would just use something like SecureCRT or Putty to ssh from Windows.
 
Top