Text on Startup

aaron

Registered
I guess this is both an easter egg and feature.

Log in not as root. Open a terminal. Type:
sudo nvram boot-args="-v"

A weird message pops up which I don't understand but it seems like an easter egg.

To actually use this feature, type:
su root
(enter your root password)
sudo nvram boot-args="-v"

When you restart, text will fill your screen and you can enjoy the fact that you have a real OS,
 

boinger

Registered
you don't need to both login as root (su) AND do an sudo. that's redundant, as sudo means "do the following command as root" and the command su means "become root". So, if you alerady su'd, thn you just need to run
/usr/sbin/nvram boot-args="-v"

(I put the location of nvram in there in case you don't have that in your path)

hope this helps!

--boinger
 

endian

Dis Member
and how exactly does text filling the screen equate with 'a real os'?
 

boinger

Registered
Originally posted by endian
and how exactly does text filling the screen equate with 'a real os'?
Some of use like to see what the computer is doing. Reviewing bootup messages can give insight as to problems you might not know existed otherwise. Particularly in a beta OS - if the computer is running perfectly all the time and isn't changed (like a server, but, then, if you're running a server with OSX-PB, you're a fool), then, certainly, turn it off.
 

JustinHoMi

Registered
This is what I got:

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these two things:

#1) Respect the privacy of others.
#2) Think before you type.

Password:
justin is not in the sudoers file. This incident will be reported.

??? I'm assuming it was *supposed* to enable verbose mode at startup, but I'm not sure what I did now!

Justin
 

JustinHoMi

Registered
Well, after a reboot, and seeing that it didn't work, I decided to try again. This time, i didn't get that funny message. I got this instead:

[localhost:/] root# nvram boot-args="-v"
nvram: Error (-1) setting variable - 'boot-args'

Any ideas? I tried entering in nvram boot-args="" and that didn't help, not to mention I tried rebooting again.

Justin
 

JustinHoMi

Registered
Originally posted by alpine
did you do it as super user
Yeah I did. Apparantly the boot params are different for some different machines. I found an easy way to do it though. Boot into OS 9 and open up the system disk app. Option-double-click on the X volume and then you can edit the parameters from there.

Justin
 
Top