TFTP permissions


Hi again.

Same thing as the previous post ... I was posting to the wrong group (I hope).

We use an AIX machine at work for our TFTP server for our switch/router configs and system images.

I tried to set up TFTP on my OS X machine but I am getting a connection error.

I have:
/tftpboot - Permissions=777
touched the file I want to upload and given it 755 permissions.

Again, TIA.
If your trying to use OS X's built in ftp daemon your beating a dead horse. tftp is a different animal yet of the same species. tftp does not use user authentications and directory visibility as does ftp. The connection mechanism is different as well, where ftp uses tcp ports 20 and 21, tftp uses upd port 69.
If you wanted to make this fly on OS X you would need to install and configure a tftp daemon. Unfortunately I can't help you much there. Perhaps some one else on this site can shed some light.
I should have put this in the original post:

I have un-commented out the tftp daemon and restarted inetd. Then, when I try to upload a configuration to the OS X machine, I get a connection error message.

ONE TIME... I was able to tftp to my laptop when I was directly connected to the switch.
Just got wind of your previous posts. I was surprised to see OS X had a tftpd, as well as some other goodies. Hoo hoo!

Back to your dilema.
-Your problem with access on a different subnet might be as simple (or complicated) as your subnets not being routed to eachother, if this is an issue anymore.
-Seems like your permissions are OK; 777 for /tftpboot, 666 for the touch file? (or is it 755 now). Perhaps for downloading images a 777 might be appropriate depending on what your device calls for and is doing with the newly downloaded image.
-Your inetd.conf.... I got this config from Cisco for the SunOS. Might be pertinent and worth a try. The -s option will chroot your /tftpboot directory so the remote host is not expected to pass the directory as part of the file name to transfer. I can't find any info on the -p option.

# Internet server configuration database
tftp dgram udp wait root /usr/libexec/tcpd tftpd -p -s /tftpboot

Hope this help.
I just did the same thing, but it appears that the tftpd in Mac os x is broken, or would somebody please clarify how to get write permissions. I set it up in a folder with perms 777 and touched the destination file, and gave it perms of 777 and even tried to write connecting through the loopback on the same box and no luck. Also, the tftp daemon is not the same as the one which shipped with the man page as it does not recognize the -s option, but it will chroot into a path provided as an argument (I know this, as I can copy files in the tftp directory down to other boxes, just can't copy a file to it).

Does changing this daemon to one that works correctly break netboot? I really don't have time to mess around with this one right now.

I would like to know though as my new employer is adverse to me bringing in my own laptop to tftp the switch configs to.

tftp works fine under OSX. It's just a bit funky.

If your going to put a file onto the server, it has to already exist
there and have world write permissions (as does the /private/tftpboot subdir).

The funky thing is that you have to specify the absolute filepath
of the destination.

So, the put command looks like:

put /private/tftpboot/

Otherwise, you get an access violation.