tftpd under Tiger?


Has anyone gotten tftpd to run under Tiger? I am now running 10.4.1 and cannot seem to get the server running properly through xinetd. I started using it under 10.2.something through inetd and it worked great. Then when that was deprecated I "tricked" xinetd to run it under 10.3.* by having xinetd parse the inetd.conf file at startup. That no longer works and I cannot seem to get xinetd to run tftpd either :mad:

I can get the server running but it can't seem to find the tftpboot directory (/tftpboot). The perms are 777 on the directory. When I have been able to get something to show up in /var/log/system.log, it's said chroot: Operation not permitted. I even tried running the server as root which isn't a great idea and it still doesn't work. What am I doing wrong?
I did some more looking around this evening and it seems that the way to start tftpd in Tiger is through /System/Library/LaunchDaemons/tftp.plist. I tried starting the server that way and I am still seeing the same errors. Anyone?
chroot: operation not permitted

sounds like the tftpd might be dropping its root permissions first, and then trying to chroot into the /tftpboot directory. In fact, you have to be root to chroot, then drop your privileges.

I wish I had a copy of Tiger, I would play around with it (I'm curious about launchd too). What is the content of the tftp.plist?
Got tftpd to run under Tiger by adding the 'insecure' flag.

Here is what my /etc/xnetd.d/tftp looks like

service tftp
cps = 200 5
disable = no
socket_type = dgram
wait = yes
user = nobody
server = /usr/libexec/tftpd
server_args = -i -l /tftpboot
groups = yes
flags = REUSE

Restart xinetd and it should work.

Permission of /tftpboot is 666, owner is nobody, grp is wheel.