That <bleeping> password won't let me in!!!


Okay, here's my story. I originally installed OS X about a month ago and for some reason the Classic Environment wouldn't work so I re-installed 9.0.4 and went on with my life. There's that file called "System" left over from OS X that is permanently fixated in my hard drive and it won't let me throw it away. I just let it sit there since there was nothing I could do about it.
One month later, I got a cable modem and wanted to see if it would work with OS X, so I re-installed OS X and when my computer starts up I am confronted with a password screen, which is normal, except that my password from the time I originally installed OS X doesn't work! I'm trapped out of my own computer. How retarded is that? I am apalled that Apple shoved all this security crap right in our face without giving us the option to turn it off.
Is there any way to bypass the password screen? I tried holding down keys and such, I can't figure out anything. So until then, I don't have a computer. If you're wondering how I was able to write this message, I still have my old beige Power Mac. My Power Mac G4 Cube is what I'm trying to use.
You can boot into single user mode by holding down the 's' key at startup.

I have not had to boot like this, so I may be a bit shaky on details, but if you do this you should be able to log in as root with an empty password (that or you will automatically be logged in as root, as I say, I haven't tried). Then you can reset the passwords you need.

You will likely get only a command line interface, not the full Aqua setup. If this is the case, then the command to do set a password is "passwd". You will for sure need to set the root password, for which you type "passwd root" , and you will probably want to set your regular user password, for which the command would be "passwd &lt;username&gt;". Once you've done this, you should be able to boot normally.
Ya hi i had the same problem as him and when i try to type "s" and then and oyu said tha tthe interface and tha did happen and it says to type in the localhost # and you did not say anything bout that so where would i find that number.
what do i do?

well, since OSX keeps all of it's user info in the netinfo database, all you have to do is delete this file. then reinstall OSX. It will create a new NI database and you will need to enter a new password that should work just fine. This will work fine, granted you haven't edited the NI database while OSX was installed.

Here's how:
1. get ResEdit, you'll need it to show some hidden folders.

2. Open ResEdit 2.1.3 and hit the cancel button on the dialog box that appears.

3. Goto File-> get info for Folder/files

4. Open the drive that has OSX installed on it. and choose the 'private' folder

5. unselect the "hidden" box and hit ok

6. Close ResEdit

7. go into the Private directory that you just made uninvisible.

8. go to var->db->netinfo

9. Delete the folder local.nidb

10. Reinstall OSX