That pesky Help Viewer problem


I've recently upgraded from Mac OS 9.2.2 to Tiger on my Mac G4. Everything's been going great, except for the Help Viewer.

Like many other users (as I've found from googling), quite often my Help Viewer (for Mac OS X, not in any specific application) stops responding. It either shows a blank screen, or else search for or clicking on links won't do anything.

The problem can be traced to corrupted preferences and cache problems. See this link for more info and the resolution.

Now this really torques me off. Help is one of the most basic functions the OS should provide. Why does this keep occurring? Does it have something to do with the fact that I use dialup? For some reason, somebody thought it would be funny to have the help viewer go off to Apple and download crap everytime you use it. All I can figure is that my dialup isn't downloading something fast enough, or gets interrupted, and that hoses things up. I finally built an Automator application to remove the .plist files and cache for me, but it's still a pain. I shouldn't have to do this. But the problem is bad. I can use Help once, but after that it's broken when I restart it, until I flush the prefs/cache.

So is there some way I can stop the Mac from going to the 'net when I use Help? Can I poison the hosts file somehow to prevent it from seeing that IP? It's a pain to have to disconnect from the internet just to call up Help Viewer.

Thanks for any input.
Unfortunately, I can't help with the problem (I came here to figure out why my help viewer died). However, I also experienced the problem while trying to use help while connected to the internet with dial-up.

I have the same problem with the Help Viewer. (After installing Tiger) When I try to access my Mac OS X Help Library from the menu, it will launch. But when the I try to click on a link, nothing happens. Nada! The link on the left of the divider to, of course launches Safari and works. I'm so glad someone else posted this problem because I've tried everything... yes the .plist routine. I've Repaired Permissions/run MacJanitor/ zapped the PRAM... no go.
So, I'm going to skedaddle on over to the Apple forums and see if I can find some sage advice there. If anyone figures out a 'fix" please repost! It would be much appreicated.

Carolyn :)
Ta da! I solved the Help Viewer dilemma. Anyone still have problems with their MacOS X Help Viewer head on over to In the Search box at the top of the page type in Onyx It's a freeware that will solve your problem and take good care of your Mac :) After you download (7 mins with 56K), install Onyx. Now, when it loads, it will ask for your admin password. Take care of that then... click where it says: Maintenance In the third box down check the box that says: Reset Mac Help
Also, check the Daily, Weekly, and Monthly scripts. Quit Onyx. Now try to acces your MacOS Help. I've tried everything else but stand on my hands and whistle Dixie.... BUT this worked! I found this suggestion at the Apple forums. :)

Carolyn :)
I forgot about Onyx since I'm using Yasu on the other hand forgot to mention I'm not yet "Tigerized" and panther version of onyx doesn't offer the "reset mac Help" function in maintenance ;)