the Application Safari Quit Unexpectedly


I installed OS X Tiger the day it was released and ever since the Safari RSS application will quit unexpectedly every time I click on the red X button at the top. I tried deleting all files that have to do with the Safari RSS including the library files and then I reinstalled the application from the OS X Tiger installation CD. The application worked about three times without the error message appearing when red X'ing out and then it went right back to having the same issue. I tried this again with the same result and then again but it didn't even work the first time on the third try.
I then went searching on the internet and found I found a fix which happened to explain the same problem I was having. The following is the fix
suggested which I tried.

First, go to Applications>Utilities and start up Disk Utility. When that opens, click on the second icon at the top left, then click on Repair Permissions.

Next, go to Home>Library>Preferences. Trash the following: file
and empty the trash.

Did you have a third party enhancer for Safari installed such as Safari Debugger? If so, you need to deactivate it, then try launching Safari.

Let me know if this corrected the problem or if it still exists.
Let me know if you need further assistance and thank you for using !


After trying this, Safari again worked the first time I opened it and pressed the red X but when I tried it again after changing preferences the same error occured. The prferences I changed include appearance - both fonts to Comic San MS,
Bookmarks - everything unchecked,
RSS -check for updates - Never,
Security - checked on block pop-up windows
and I changed the default download folder to a file on my second hard drive (internal) named safari downloads.

I have a Powermac G5 with Dual 2.5GHz processors 3Gigs of RAM and the NVidia 6800 ultra video card. I never had any plug-ins installed for safari. In case that helps with anything or rules out anything you might think the problem is.