The untouchable trash



Some how items that the current logged in user does not have permissions on got into the trash. I do not have permission to move the items out (for sudo rm -rf tempdeletefolder) nor just a simple empty trash. The trash itself does not seem to be a "normal" directory in the file system. I cannot find the directory manually and Sherlock will not find items in the trash.

How do I get rid of these things?

I also know that when and if I get permission to delete these files - I may have another issue because many are locked. rm does not like locked files.

this isn't much use, because i forgot the code and were I got it from, but there is something that you can type into the terminal to make it possible for you to move items you don't have permission for... it might have been on

You might try asking about it in one of the Unix sections...

WAIT!!! I found the code! just follow these easy steps!

1. Open the Terminal utility.
2. Type: ' sudo chmod 775 /'.
3. Press Return.
4. Enter your password and press Return.
5. Using the Finder, move the item(s) back to its original location.
6. In the Terminal, type: ' sudo chmod 1775 /'.
7. Press Return.

I don't think you include the 's...

if that doesn't work I can't help you...

Hope it does though!:p

I beleive the chmod command you specified will alter all the files below root directory! My computer has and needs the security of multiple users.

You can do
"man chmod" and "man 2 chmod" from the terminal to get not-so-great documentation. chmod does have an alternative syntax that is more readable.

"chmod a+rwx ~" will add read/write/execute permisions to your home directory for (a)ll users.

The "/" represents the top of the file system and "~" represents the home directory of the curren t user.

The question is what directory can I do a safe chmod to that effects the trash?
I was having the same problems, logged in as root. I found the problem to be the invisible files. I just could'nt delete them. For example AppleWorks 6.2... I gave up and deleted the files when started up uner MacOS 9.1

I don't really know what to do, the only adive I can give is to do it in Os 9.1 until someone else knows what to do about it...
That is what I had to do.

One of the confusing parts was the X trash can does combine the trashes from multple volumes. On my 9.1 partition there is an invisible directory called .Trashes with user identification sub directories. Some one in the Unix thread helped me figure that one out.

I used resedit to make the ~/.Trash and 9.1/.Trashes visible and delete the files the old fashioned way.
And, after all that hacking, if you're still not allowed to empty the trash because of locked files, it turns out that you can just hold down the option key while you empty the trash, just like Mac OS 9...
Have fun in unix.... oi vey. heh.

The option key was the first thing I tried! It did not work for the hundreds of locked files I was trying to trash :-(