Tiger And Adsl


hi people!
i have mac os x tiger and for internet connection im using an adsl modem that includes a simple router function in it(the modem is from "CORECESS" and is a 3115 series model).
everytime i try to connect to the internet with ofcourse the right username and password which i use for connecting via PPPoE connection that takes automatically an ip-address after a while i see a pop-up window which tells that it couldn't negociate a PPP server and i should check my settings and try it again.
on the other hand with a windows running pc i can connect easily to the internet.on the mac(G5 dual 2.5Mhz etc) it can connect each 1 of 1000 times that i try.please help me how to connect to the internet and i should mention that it is the only good ISP and ADSL modem that is available in my country and im sure that the problem is from my side and not from the Internet service provider.
thanks for your time...
A couple of questions to tackle the problem:
  • Do you connect via PPPoE from the Windows PC as well? If so, the user-data collides at the ISP, and he blocks it (not to allow abuse, no log-in from two places at once)
  • Have you tried to connect only with the Mac, without the PC connected to the net? You can verify the point above with that.
  • Can you put your user data on the router?
  • Does the router support a DHCP server? If not, have you defined a static IP for the Mac?

That should basically cover it. :) You should check those points, chances are good you stumble over the solution during that. If not, just post again. :)
yes i connect via PPPoE, and no im not even able to connect both pc and mac at the same time.i do it separatly but it figures it out on a windows machine and on a mac it cant.it has only an ethernet cable so it can be connected only to mac or pc at the same time!
i can configure the router so that it automatically connects to the ISP so i can put my username and password in the router or DASL modem configurations.its also able to connect via PPPoA and many other ways like macspoofing option and i can configure a gateway and DHCP and all this, but my problem is that i cant configure it correctly.so its my first time configuring things like adsl modem or like you called it router!i also dont know how it makes the handshake with mac there are also many options like adsl configuration as i mentioned(PPPoE/PPPoA/1438 LLC/1438 VC Mux...).
Hm, I checked the manual for the thing online. As configuring the Mac is not specifically mentioned there, I'll not the steps for the same configuration they mention in their manual for Windows XP:
  • open the System Preferences (normally resides next to the Finder in the Dock)
  • go to the Network Panel
  • click on "Ethernet (internal)" (or similar, I don't know the exact wording) in the second pull-down menu displayed
  • in the TCP/IP tab, chose DHCP from the pull-down menu
  • enter a Domain-Name if you wish
  • click on the save button in the lower right of the window
  • Finished

The manual I got from the website was for installation of the hardware only, so it does not say anything about the configuration of the router itself. That normally works via an built in Web-server you reach with a web browser running on a computer linked to the router. You will have to log in there and enable DHCP and enter your SP user data there. Then you should have no problems when switching. From all I could gather, you will have to use a second hub to connect more then one computer with ethernet (unless it does have the optional USB port)

You'll have to consult the manual that came with the thing for the web setup, I never worked with this router so I can't really walk you through that
i had a long discussion with the ISP specialist he learned me how to setup a dhcp server in it. it has 15 local ips with NAPT enabled for each of them. Now i have a NAT problem and portforwarding doesn't work.The ISP says thats my problem so if it doesnt work i can buy myself a windows pc(crazy pips).
so give you some infos about my Router config:
it has DMZ(i tried that out for portopening but it didnt worked), IMGP(what is that, can this help me in any way?), DHCP Relay(couldnt figure also this out), HTTP Server(that is default set to All it can be set to Restricted but then i can check 2 boxes one is for LAN and the other one is for WAN. if i check WAN then there is a box to insert my ip and subnet mask and a port (default is 80).these all are under HTTP server setted to restricted.
so if one of them could help me with my NAT prob just tell me.