Tiger and linux SMB browsing

cbolin

Registered
I have a VERY simple SMB server running linux that all my windows and linux boxes use.

Code:
[global]
workgroup = home
netbios name = homeserver
server string = home data server

[public]
comment = data
path = /data/public
force user = samba
force group = users
read only = No
guest ok = Yes
All samba clients can connect as expected and work great. But with my new Mac, I can only see the workgroup - but when I click on the server I get the spinning rainbow of death and have to restart Finder or it never ends.

What am I missing?

Thanks for helping a mac virgin!
 

HomunQlus

Artifical Lifeform
I have two shares set up on my Samba (Knoppix 3.7 HD Installation).

Code:
[global]
workgroup = albombanet

[uploads]
path = /serverdrive/uploads
browseable = yes
public = yes
writable = yes

[downloads]
path = /serverdrive/downloads
browseable = yes
public = yes
writable = no
This works very well for me, can connect from OS X and Windows clients without problems.


P.S.: /serverdrive/uploads has chmod 777 while /serverdrive/downloads has chmod 755.
 

cbolin

Registered
Thanks for the post - copied your smb.conf to verify and it doesn't work for me.

I don't have any firewall running either.

When I try to connect... to the server, I have to restart finder or I watch the rainball forever.

What linux version and samba version are you using?
 

cbolin

Registered
I've stripped down my smb.conf to read just:

Code:
[global]
workgroup = HOME
server string = server name

[public]
path = /data/files
read only = No
guest ok = Yes
ALL windows and linux clients of various versions connect to this fine. No troubles. My MAC OSX 10.4.2 machine won't. I've tried with SMB allowed with the mac firewall and the mac firewall completely stopped.

I am running samba 3.0.14a on my Linux server. The directory /data has permissions 777, the directory /files has permissions 777.

The problem must be on the MAC.

Very frustrating. Any other ideas or help?
 

Ripcord

Senior Lurker
What happens if you try to connect directly to the server instead of browsing to it? One method creates a direct mount, the other one creates an "automount" of sorts. When I hear complaints about OS X SMB compatibility users are usually trying to use the browser (which for whatever reason seems especially buggy).
 

Ripcord

Senior Lurker
Not you...cbolin. We already know yours works.

...And I really mean either running smbmount, or trying to connect to his shares by going to Finder, hitting CMD-K (or Go->Connect to Server), then typing in smb://<IP address of SMB server>.
 

thekurst

Registered
When I was having problems getting my Mac to connect to my linux share I had to make sure encryption was enabled in my smb.conf file because tiger is funny like that.
 
Top