Tiger "custom" Date Formats

xpb

Registered
The OS X prefPane "International" lets you select from among various national date formats, or to set a "custom" format from its basic ingredients. However, there appears to be a bug in the prefPane such that if you set any one of the four date formats (known as Short, Medium, Long, and Full), the other three revert to (US?) default.

I'm trying to do this so I can maintain the ISO date format YYYY-MM-DD throughout the system and throughout apps that pick up the system date format. (Apple didn't include ISO as a standard alternative.)

I presume that the prefPane is simply a convenient interface to some file(s) where the desired format is really stored.

Question 1: can someone say where that file is, and if so whether/how it could be modified without going through the prefPane?

Question 2: Alternatively, a fix to the prefPane would be nice.
 

driftwolf

Registered
I'm also getting the same problem. Apple's version of "Canadian" time standard is pretty screwed up (as in, they think we're Americans). Trying to fix it and not having any luck at all. Direct access to the necessary files would lovely.

Anyone?
 

Giaguara

Chmod 760
Staff member
Mod
Different programs take in practice the time from different parts of the OS or code, so thatswhy not all programs actually respect the customized time setting.
 

xpb

Registered
The file ~/Library/Preferences/com.apple.systempreferences.plist includes the ONE custom date format set by the Interational preference pane. You can see it (in terminal) by the command:

defaults read com.apple.systempreferences AppleIntlCustomFormat

For example, my custom setting of the Long date format shows up as:

{
AppleIntlCustomICUDictionary = {AppleICUDateFormatStrings = {3 = " yyyy-MM-dd"; }; };
AppleIntlCustomLocale = "en_US";

Experiment indicates that 3 means the Long Date, 2 the Medium date, 1 the Short Date.

Using a Plist Editor, I tried modifying the systempreferences.plist file to insert two additional siblings of the one that sets 3 to "yyyy-MM-dd". In this way I inserted custom values for 1 and 2.

I verified that this change had been entered (and was reported by the "defaults" command). However, it did not seem to take immediate effect. So I restarted the system--- and found that my insertions had vanished from the file. So either I didn't do it right, or some other check dislikes having more than one custom date, and deletes them.
 

driftwolf

Registered
Giaguara said:
Different programs take in practice the time from different parts of the OS or code, so thatswhy not all programs actually respect the customized time setting.
True, but we're talking about the System Preferences pane here, not just any application. Preferences menu. Changing "Long" to the correct setting resets "Medium" to an incorrect setting. Setting "Medium" then changes "Long" and "Short" back to their (inaccurate) defaults. And so on.

That hack I used was that I selected the Ireland date settings, reset the money value from Euro to "Canadian dollars", then it seems to work ok. Still, much as I liked Dublin and Galway, it would be nice to have the computer in the same country as me... :)

cheers,
Marc
 

driftwolf

Registered
Interestingly enough, changing the country doesn't change the preference pain (sic) bug, but it does change its behaviour.
If I start with "Canada" then modify things, it displays "Custom". However, it seems to rememer that my last country choice was "Canada" and selects USA-style formats when it changes things on its own.

If I select "Ireland", then customize, the bug is still there. However, the system remembers that my last choice was "Ireland" and changes the formats back to THAT standard.

Quite odd really.
 

xpb

Registered
I tried again to edit com.appple.systempreferences.plist. This time I rebooted from another drive, and inserted the changes while I was sure that the file was not in use.

Immediate result: when rebooted from the drive with the modified file, the system hangs.

Next result: after again rebooting, the system works, and com.appple.systempreferences.plist has been restored to what it was before I tampered.

Next experiment: I renamed com.appple.systempreferences.plist and did not replace it.

Upon rebooting, the file has reappeared, and contains the same settings as before I tampered. Either it can find the renamed file, or a version in the trash, or, (more likely? upon finding the file missing, the system reconstructs it from some other place in which the info had been saved.

This seems similar to the behavior reported by driftwolf.

A friend reports that when he first installed Tiger, he was indeed able to use the International Formats prefpane to set all four of the date formats. And they worked. But as soon as he went back to the prefpane to demonstrate to me how nicely this works, his too began to retain only one of the four formats he'd set, while the other three reverted to the defaults for his locale (in his case, eng_us).
 

xpb

Registered
After much experimentation, I believe I have stumbled on a way to avoid the problem with custom date formats described earlier in this thread. Here's the problem and how to avoid it:

In the Tiger preference pane International>Formats there's a button labeled "Customize". Pressing this button opens a new pane. At the top left of the new pane is a scrollbar labeled "Show:" with the options "Short, Medium, Long, and Full." To customize all four settings, you should step through the four choices. At each choice, you can assemble from the palette of ingredients the date format you desire.

None of your customizations will take effect until you finally press "OK". But do NOT press "OK" until you have set all four options. Moreover, you should set the options in a sequence such that "Full" is the LAST one set.

Press OK when "Full" is showing, and all four of your custom formats will be recorded. But press OK when anything other than "Full" is selected, and only that one choice will be recorded, while the other three will revert to the default values for the Locale (language/area) that was in effect before you started to customize.
 

Esquilinho

Registered
I'm running 10.3.9 and I have more or less the same problem.
I can't choose Portugal in International, because if I do, when I try to create a calendar event in Entourage, it always ends up in December, whatever date I choose.
So what I've been doing is choosing Ireland and customizing the formats to my taste.
But lately, everytime I restart my mac, it always goes back from 24h clock (whcih is what I chose) to AM/PM!
I'm not sure about it, but I suspect this started happening after updating to 10.3.9... An ideas how to solve this issue in Panther?
 
Top