Tiger does not see all files


I tried doing the search first, but the web site did not produce a result page...

Tiger is not seeing all files in two places:
1) On DVDs I burned. Using DVD-Rs, I burned several 4BG+ DVDs. When I put them in, Tiger will only see 1.17GB worth or so. What's with that?

2)I have an NTFS hard disk from my old PC. It has been thoroughly "scan-disked" and defragmented. It has roughly 50GB worth of information and 9 main folders. Tiger only sees about half the info and half the folders. Again, what's up?

Thanks for your responses.
It is a PowerBook G4. I am new to Mac, so bear with me. Repair the permissions on my Mac in System Preferences or repair the permissions on the files themselves (I can see all the files on WinXP)?
If the former, to what do I set the permissions?
Applications / Utilities / disk utilities. Reparir permissions (on everything). might work.
is there any system to the things you can see and the things you can't? (like do you see everything from A to L, but not from M to Z, or do you see a certain kind of files?). can you spotlight-search for the files?
Thanks Decado, but....
I tried Disk Utilities. For both the external NTFS hard drive and the DVD-R, all First Aid options, including Repair Permissions) are greyed out. But they are not greyed out for my internal Mac hard disk.
There does not seem to be any pattern to the missing files and folders. To be more concrete, I simply want my music from my external NTFS hard disk onto my Mac. That entire folder called "Music" is not seen in my finder window. But, for example, "Videos" which is much larger in size is seen.
I also tried Spotlight Search. While it did find other folders I can already see on the hard disk, like "Videos," it did not see "Music."

Any other suggestions or experiences similar to this?
i dont know anything about windows, but could it be that these folders (the missing) belong to a certain user on the windowsmachine, and therefore can't be accessed by others? connect the harddrive to the pc again and move some files out of the folder and then connect the harddrive to the mac again and see if you can see the files.
Not a bad guess, but what you suggested about different users owning the folders is not the case, I'm positive.
Anything else?
hm... how about selecting the drive (in finder), choose Show Info (apple-i), go down to permissions and give your user full read-write rights to all subfolders.

but it is very weird. the should not be invisible.

drag the drive or dvd to a Terminal-window (you find it in applications/utilities) and write ls (that is a L and a S as in LiSt) and see if you can see any of the missing folders there.
I was not able to change permissions on the DVD and harddrive.

Terminal saw the same files Finder did.

Any other suggestions?