Tiger Freezes On Start Up


I have a nice new iMac G5 running Tiger. This is a business computer for my small bookstore that I just opened less than a week ago. I have a book inventory/cash register program from a third party developer, which he has repeatedly assured me is compatible with Tiger. I also have a scanner for reading bar codes by Opticon and an Epson receipt printer.

The iMac works great, but the bar code scanner has never worked very well (often won't read bar codes, although they are recognized by the program when I type them in manually). A few days ago, the inventory application started shutting itself down or freezing (this happened 4 or 5 times over the course of business that day). The next day, the iMac (which had been sleeping overnight) was off when I came in. It is plugged into a surge protector and I just figured the power had gone off overnight. When I restarted it, I got the apple screen with the endlessly spinning cursor. I turned it off, and when I tried to start it again, I got the broken file. So...I disconnected the receipt printer and the scanner (and my regular printer and my internet access) and then started up from the installation disk and ran permissions and verify. It needed repair, so I did that. I was scared of the scanner and printer, so I left them disconnected all day and did business manually. I talked to the program developer briefly and he swears that his program is fine (I had talked to Apple support and they said his program was the problem- he said that was a "cop out" on their part).

Today I come in and turn on the computer and the fans start running and it prints out a bunch of text and gives me two options- to run some kind of repair program (I think) or to shut down. However, I have a wireless keyboard and when I typed "shut -down" I don't think it could "hear" me. So I shut it down with the power button and re-booted from the install disk again. Ran permissions and verify and that didn't find anything. So I started back up normally and it did start, but now everything is glacially slow and I am constantly getting the spinning beachball. Help! Do I need to un-install the third-party program and all its related drivers? Or what is going on? Thanks.