Tiger Mail & Imap Server


I have 2 macs with Tiger installed. I am having the same problems with both. We have an Apple OS X Server (Jaguar Version). We are using it as an IMAP mail server. Every version of the Apple Mail client thru Panther has worked great.

However, since upgrading 2 computers to Tiger, neither client is working with the server properly.

Sometimes, we will not see the most current emails. (We can still see the with the Panther version of mail on other machines).

Sometimes, after "Rebuilding" the mailbox, no mail at all will show up for that Mailbox even though it is still on the server and shows up perfectly on the Panther machines.

I have tried Sync-ing, Rebuilding, restarting, deleting mailbox file and starting over. All to no avail.

An Apple Genius thought it may have something to do with the Jaguar mail server which was replaced in Panther Server and, again, in the new Tiger Server. I always thought an IMAP server was based on standards which should make no difference.

I filed a bug report with Apple when I discovered this spectacular bug in Tiger 10.4.2, Mail Version 2.0.3 (734). It only applies if you are using an IMAP server and you are using the folder synchronization option from the Advanced tab of Account setup.

If you do NOT store your email in your home directory on your IMAP server , but rather somewhere else on the server (in my case /var/mail/me) then when Mail attempts to synchronize the first time, it looks in my home directory (~me) and gets all the filenames there, directory names too, and then begins looking for mail folders in /var/mail/me with those names. Then it gives an endless stream of "folder not found" dialog boxes. Then you must force quit. Then you must delete all the newly created mail folders in Mail app with names like ".bash_profile" ".xinitrc" etc.

The reason I know this is a true bug is that I discovered on a hunch that if I use "//var/mail/me" as the IMAP path prefix (yes, double leading slash) -- then, and only then, did the Mail synchronize operation look in the correct location, and function properly, as it had done with Panther.

I recreated this bug three times in succession, with newly created mail accounts and also with newly created Mac user accounts, the last time with an Apple specialist on the phone with me. Apple did not care that I had found this and apparently nobody is looking into it there.

I write this in hopes that something here is in common with your setup and you may need a double leading slash.