Tiger, Photoshop, and a retreat back to Panther?


I'm starting to really regret installing tiger. I've got a g3(900mhz) ibook with 640 ram. Aside from the slow downs that are occurring, my biggest problem is photoshop. I've been following the "photoshop won't double click" thread for a bit now, and my problem is similar but not quite the same. Photoshop will launch, but it opens no image file, period. I keep getting "could not complete request due to program error." I started with 7, but bit the bullet and got CS. Same problem. Resinstalled both apps, no joy. Trashed the pref files, CS worked once, but not again. Neither of my printers will work, depsite updates and reintsalls. I'm a photographer by trade, and I need these apps and equipment. Tried to reinstall Panther and the installer disk will not overwrite the "newer operating system". I really, really, don't won't to format my drive here. Can anyone please tell me how to either fix photoshop, or clean install back to panther?
I've never heard of a Photoshop problem quite like this before. My first step in diagnosing the Photoshop problem would be to create a new user account and see if Photoshop runs properly there. If it does, you can narrow down the problem to something in your Home folder — preferences, Application Support, etc. If it doesn't, you know it's system-wide — possibly something in /Library (although one would think reinstalling CS would fix such a problem...).

As for going back to Panther, I've never done it myself, but I would think you'd need to do an Archive and Install, and then either manually move all your custom stuff from your current (Tiger) Library to the new (Panther) one, or just reinstall all your third-party software yet again (which might be safer, but would obviously be a hassle). Or does it not even let you do that?
I set up 2 dummy accounts, one adminstrator, one user. Same thing. Photoshop will launch, but not let me open any image files. Not even
GIFs. Won't let me create new documents either. (I'm starting to miss the days of extension conflicts, at least those you could track down.) I'm fairly new to OS X, but is there something like a Zap Pram feature or Desktop rebuild in this OS, and would that do me anyhting? I've repaired permissions on the disk, but that didn't appear to do anything either.

I'm drowning here....