[tiger svr] Can't add users to open directory


We've been starting to expiriment with getting an open direcotry server working and it's been working fine for a week or two now except all of a sudden i can't modify users anymore.

I am using directory administrator and tried logging in as both diradmin and root and I can login fine, I can change the passwords of users fine, but I can't modify any of their settings, can't add or remove anything, etc. If I switch to the local directory on that server it works fine. I have tried it both remotely and from the server itself. If i look at both diradmin and root, they both have all three checkboxes on the "Basic" page for the user (User can...: administer the server, adminster this directory domain (can't see properties because it is greyed out), access account). Logins to the server work fine, as well as using it to lookup contacts and don't see any errors in the logs. Obviously, this isn't something we want to come accross once we put this into production. The Open Direcotry Adminstration pdf from the apple site doesn't mention this in the troubleshooting, I even tried logging in as root and changing the password of diradmin to something else to see if it would 'rebuild' that account. Although I'm guessing their may be other issues if neither root or diradmin can modify any users (except change passwords). And ideas would be appreciated, thanks.
Fixed it, I made an archive of the open directory using server admin, change it to standalone server to delete the open directory, then recreated the master open directory with same credetials as before. Restored the archive I made and it worked. I thought I would have had the same problem since I though the archive did everything but maybe there were some indexes that got rebuilt when i did this and when I restored the archive it just recreated those indexes.