Trouble Finding Airport Hardware After Powerbook Awakes From Sleep


I haven't been able to figure this one out:

I have a Titanium PB G4, 867mhz, 512MB RAM. Currently running 10.4.0. I know that this problem never existed prior to the transtion from Panther to Tiger, but I am not sure that it has ALWAYS happened since the upgrade to Tiger...

I use a third-party wireless card, inserted into the PC card slot of the PB (it's a Belkin 54g that uses the Broadcom chipset, and which Max OS X's Airport software simply recognizes as "Airport Card"). Lately, whenever I turn the Airport off (using either the signal strength menu "widget" at the top of the menu bar, or using the Internet Connect application), then remove the card, then put the PB to sleep, it will no longer recognize the card upon awakening.

What happens is that the card itself shows up in the menu bar, but when I go to the Airport menu "widget", the only option says "No Airport Hardware detected". The only way I have been able to resolve this is to restart - a Log Out will not fix the issue, nor will switching to a newly-created empty user account.

If, after a restart, I insert the card, it is recognized. I can then turn it on, and the Airport software connects to any open wireless network just fine. If I then put the PB to sleep WITHOUT turning off or removing the card, it will still be recognized and able to connect when I later awaken it - but this is impractical when I am moving from place to place.

I have tried trashing any "airport" plists in the Preferences (I only found any in Home:Library), but with no change. I also have been unable to find any helpful information on either Apple's support site, or on the internet at large. There is a similar issue discussed where the software will no longer reconnect automatically to a given network, but I haven't found any mention of the software simply not recognizing the hardware, as I am experiencing. Like I said, this never happened under either Jaguar or Panther.

Any help or insight would be appreciated.

You are not hallucinating...I have EXACTLY the same problem. I am using a Belkin "G" card and cannot get my PB G4 867 to recognize it after removal and re-insertion. I just posted a note that reads identically to yours on the Apple Support Discussions site.

I upgraded to 10.4.1 on the weekend and the problem has been consistent since then. The only other difference is that I have 768MB of RAM. Let's see if there are any more of us out there...
...more information...

The same thing happens when I try to switch to my Sprint PCS mobile phone and use Vision to connect to the web. I have to re-start the computer and the phone in order to have the phone even show up in order to connect. That was not true before.
And yet more information...

The PB was closed and asleep, and I put the Belkin card in before I opened it up. I had left Internet Connect open. I chose AirPort as the connection, clicked on the "Turn AirPort on" button and also clicked on the check box for "Show AirPort status in menubar". None of the wireless networks available showed up in IC, but the icon showed up in the menu bar. When I clicked on it, the wireless networks were listed. I selected my home network--rather than those of my neighbor--and it worked.

I had tried putting the card in at first several times before, but hadn't used Internet Connect. Obviously that "unlocked" something...anyone know what?
For all who care, or who didn't--it seems we weren't the only ones with the problem. Apple obviously heard of the problem, as it appears to have been fixed in 10.4.2 (the upgrade to Tiger available at

I've upgraded, and all appears to be as it should be--the PB finds the card and logs on to the network after sleep and/or removal of the card. Wonderful!



OK, I take most all of that last post back... The re-start worked after a little while, but when putting the 'Book to sleep for awhile and removing the card, I could get nothing to work again until I restarted. None of the short-cuts I discovered in Internet Connect or Network prefs worked.

Any other ideas? I'm a bit frustrated here.