Trouble getting Speedtouch 510 ethernet router / modem to work


anyone with any ideas on how I can get my speedtouch ethernet router / modem (510) to work? I am not very technical but have tried everything and followed all the instructions. It will not connect to the internet (eventually I want to use it with my new airport which was why I had to get it) and it doesn't seem like it even exists to my computer. Help!


Hmm - it's not cold where I am.
(I'll explain if that doesn't make sense to you, samui.)

If you plan to use an Airport base station, or even Airport Express, you didn't need the model with router built-in.
But it should still work. Do you have your Mac set to Configure IPv4 using DHCP? Do you have PPPoE OFF in Network prefs, too? You need to set up the router to use PPPoE on its own to authenticate for you with the ISP. and the router is both DHCP server and client at the same time.
Does all that sound familiar?


to be honest it's not that hot where I am either!
thanks for your tips - unfortunately it's all set up as you've said - and still not working! I don't have anything in the DHCP Client ID box in Network prefs though (don't know what this should be!) maybe this is the problem? So to answer your question it all sounds familiar (vaguely!) except the router being both DHCP and client at same time bit! Any other hints???
Meantime any suggestions on what modem I should have bought as I'm ready to throw this one through a window!?