Trouble with Personal Hotspot over USB from iPhone

Highmastdon

Registered
I used to use Personal Hotspot on my iPhone with USB in order to not to drain my battery. But now it seems my iPhone doesn't get found by my MacBook Pro. I've got Mac OS X Snow Leopard. This problem occurred since I installed something like DiskAid or some tool to 'browse' the iPhone like iPhone Configuration Utility. I've tried to uninstall it, but I don't get it to work.

Does anyone have a solution for this or point me in the right direction.
 

Highmastdon

Registered
I used to use Personal Hotspot on my iPhone with USB in order to not to drain my battery. But now it seems my iPhone doesn't get found by my MacBook Pro. I've got Mac OS X Snow Leopard. This problem occurred since I installed something like DiskAid or some tool to 'browse' the iPhone like iPhone Configuration Utility. I've tried to uninstall it, but I don't get it to work.

Does anyone have a solution for this or point me in the right direction.
As mentioned here: https://discussions.apple.com/message/18057392#18057392 I'm posting this to help others. Now I'll try it myself and come back later.

Hello,

I get it back working. Great deal. It was the iPhone configuration utility, which causes the trouble.

What I have done

I switch on the iPhone hotspot via USB
I checked the system logs and found the following entry
06.04.12 18:39:40,531 com.apple.kextd: Can't load /System/Library/Extensions/AppleUSBEthernetHost.kext - no code for running kernel's architecture.
I searched for that message and found the solution in https://discussions.apple.com/thread/3787866
I remove the kernel extension and reinstall the last version of iTunes.

Gread deal, it works without any reboot. Just out of the box.

Thanks all.
Found another thread where a solution is offered.
 
Last edited:
Top