Trying to reinstall XDarwin


I was having issues with my XDarwin so I tried uninstalling it. I followed these guidelines:

'dpkg -r --force-depends system-xfree86'


sudo rm -rf /usr/X11R6
sudo rm -rf /etc/X11
sudo rm -rf /Applications/
sudo rm -rf /Applications/

I then downloaded XDarwin from the Apple site and still get a message that the software I was installing is older than what I have on my machine. Is there something I an doing wrong?
take care


(1) Are you certain that "system-xfree86" is the name of the package?

When I look in /sw/var/lib/dpkg/available I find a package that includeds...

Package: xfree86
Section: x11-system
Installed-Size: 0
Maintainer: Benjamin Reed <>
Architecture: darwin-powerpc
Source: xfree86
Version: 4.4.0-13
Replaces: xfree86-base, xfree86-base-threaded, xfree86-rootless, xfree86-rootless-threaded, xorg,
Provides: xserver, x11-dev, x11, rman, libgl-dev, libgl, xft2-dev, xft2, fontconfig1-dev, fontcon
Depends: xfree86-shlibs (>= 4.4.0-13), darwin (>= 7-1)
Conflicts: xfree86-base, xfree86-base-threaded, xfree86-rootless, xfree86-rootless-threaded, xorg
, system-xfree86
Size: 49126810
Description: Free X11 implementation for Darwin and Mac OS X
XFree86 is a free X11 implementation that supports Darwin and Mac OS X.
This will let you run X11 applications and desktop environments.
So the "package" name is xfree86 and the "system" is x11-system.

(2) When you remove a package it should remove the executable for you. If when you ran sudo rm -rf /Applications/ you didn't receive a error, "No such file or directory" then dpkg didn't remove the package.

Use dpkg -l to list a summary of all installed packages. Use dpkg --help to list available options for dpkg. Check that you do or do not have the X package still installed.