Ulysses is driving me nuts...


Chmod 760
Staff member
Whenever I try to launch a file, even one I just created, in Ulysses, I get

The operation couldn’t be completed. (Property list invalid for format (property lists cannot contain NULL) error 0.)

It's driving me nuts.
It's been since I got my system to 10.9.
Now it's 10.9.4, and Ulysses 2.2 (build 2.2).
Now there IS a newer version of Ulysses available, but it's Ulysses 3 and it's not a free upgrade. I'd rather get this one to run on my system first, then upgrade later when or if I feel like it. And NOT just because my app refuses to function.
It worked fine before 10.9. Although then it was on a different Mac, and I think in 10.7.

Deleted preferences in ~/preferences for it.
Reinstalled the app from app store a few times.
Tried to hunt down for WHAT property in a file created by Ulysses is null or not defined. Created even new files with nothing other than name on them, and it's still the same thing...

Without being able to open the files, the app is useless.
I could of course go open the files, and save each text file manually - but as long as the only way to get anything out of the app, it's rather useless and I might just Evernote instead.

So any suggestions what I might have missed or what else would be worth a try?
I do want to be able to get to my files created with it, and keep writing with it.
I can't find any recent support anything for Ulysses 2 anywhere.

Also suggestions for a replacement may be an idea.
So if I have to just go to Ulysses 3, I could as try something different.
Something like Write Room on steroids; I like the simplicity but I do want to have the whole project at once, and keep a track of all files and work on different texts on teh same project at once.
Hm, that might not be a bad option. Nope, hadn't looked at that one before with that eye, but will do. :)